Welcome to Comcast Help & Support Forums
You can contribute an answer or post a question.
Reply
Posted by
New Visitor
Member Since: ‎07-19-2012
Posts: 1

Access comcast email when it says to refresh my browser

I can't access my comcast emails.  It says to refresh my browser which I've done and it still doesn't work.  HELP

Posted by
Silver Problem Solver
Member Since: ‎02-22-2007
Posts: 6,127

Re: Access comcast email when it says to refresh my browser

Hello,

Have you tried a different browser?

Have you cleared your browser cookies,cache and history files?

Have you tried to go to m.comcast.net/m and see if that will work?

What email client are you using if any?

Are you using the xfinity lite or full?

What os are you using?

Has it been working before and if so did you add anything new?

What have you tried to fix the problem?

Have you search in the forum to see if other customers have the same problem and see what they done to fix the problem?

Posted by
New Visitor
Member Since: ‎07-19-2012
Posts: 1

Re: Access comcast email when it says to refresh my browser

I am having the same problem

Posted by
Email Expert
Member Since: ‎05-21-2006
Posts: 29,136

Re: Access comcast email when it says to refresh my browser

If you look through the many threads in this forum, you will see other users with the same issue. Comcast is aware of it and is working on fixes. Whenever a fix is tested and then implemented, the XfinityConnect Team will update information in the forum.


Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Posted by
Visitor
Member Since: ‎01-10-2009
Posts: 4

Re: Access comcast email when it says to refresh my browser

Just for the record, I am having the same problem.  Clicking the refresh button doesn't work.  Anyone have a quick fix?