Reply
Visitor
Posts: 4
Registered: ‎12-10-2008

Cannot receive incoming e-mail on my Mac

Am suddenly unable to recieve my Comcast e-mail from my mac mail account, though am able to send e-mails. The pop up Alert says "the server error encountereds was: The connection to the server. "mail.comcast.net on port 110 timed out." This has occurred in the past, and the "Connection Doctor" says the login and account are fine. What next?

Web Page Expert
BethKatz
Posts: 6,136
Registered: ‎11-14-2006

Re: Cannot receive incoming e-mail on my Mac

Look at the top of this forum at the Mac settings. Change the incoming port to 995 with password authentication and SSL turned on. Change only the incoming port. The outgoing port is different. Save the setting by choosing some other part of preferences.
Visitor
Posts: 4
Registered: ‎12-10-2008

Re: Cannot receive incoming e-mail on my Mac

Thank you, Beth.

Please excuse my ignorance, but I am not clear as to where to locate the Mac Settings you spoke of at the top of this Forum page to make the Port change you recommend. However, in my Mac Preferences/Account page, I did try to change the Port number to the 995 and checked the SSL box. Underneath that the Authentication box had the word "password" listed, which I assume is the password I use, but I found no choice of Incoming Port, nor any way to confirm that change and as soon as I left that page it reverted back to the Port 110. Still no incoming Mail for over a week now, I welcome any other assistance.

Visitor
Posts: 4
Registered: ‎12-10-2008

Re: Cannot receive incoming e-mail on my Mac

Addendum: I did Save my Port Changes to 995 and the SSL box, but to no avail. Mail still not coming in.

Web Page Expert
BethKatz
Posts: 6,136
Registered: ‎11-14-2006

Re: Cannot receive incoming e-mail on my Mac

Look at the pictures in this thread -> click here

 

In particular, you need to set the port for incoming to 995, turn on SSL, and use Password authentication.

 

If that still doesn't work, go to the Window menu (next to Help menu in Mail) and choose Connection Doctor. Tell us what that says.


I trust you are able to log in to Xfinity Connect on the web through your web browser.

Visitor
Posts: 4
Registered: ‎12-10-2008

Re: Cannot receive incoming e-mail on my Mac

I followed all the screenshot directions you sent, which ask me to set up an additional account. After entering my password, always got a popup  saying, "The account "aleder" already has this host name and user name. Tried several different passwords, got the same pop up. Can't change my host name. Am I supposed to create a new username entirely? If not, I can't move forward from here.

 

Also, as I've done before, logged onto the Connection Doctor. At the top, "Connection Status" with green dot says "Mail was able to connect to the internet. In Status box, I have a red dot next to aleder. Under Details it says: "Logging into account..." Beneath that is a green dot and "Alan Leder eMail". To the right it says: "Connection and login to server succeeded". No further details.

 

Yes, I am able to log in to Xfinity Connect on the web through my web browser and am able to access my e-mails form there. Always have been able to access that. But, that's secondary. I need my primary Macmail to function. So far, 6 days in and no incoming mail, even after I've tried all suggestions.

 

 

Web Page Expert
BethKatz
Posts: 6,136
Registered: ‎11-14-2006

Re: Cannot receive incoming e-mail on my Mac

No, you're not supposed to set up a new user name. I should have been more explicit. I should have suggested you go into Mail > Preferences > Accounts and then clicked on your existing account. 

 

Then you need to set both the incoming server information and the outgoing server information.

 

But from what you said, Connection Doctor seems to think everything is fine. 

 

Is there mail to be downloaded? If you send yourself mail, does it appear online but not get downloaded?  If all your email is missing online, I'd wonder if your password had been stolen. But that doesn't sound like it is happening.

 

Is the account listed as active in Mail? Did the check box in front of 'Enable this account' get unchecked? Note that I remove messages from the server when downloading, but many people do not.

 

MailEnable.jpg