Reply
Bronze Problem Solver
lunski
Posts: 1,757
Registered: ‎09-03-2008

E-Mail Client Settings (customer generated)

[ Edited ]

The below information was organized and submitted to ComcastGeorge by CCCarole, Joel, JR0171702.

 

Please send them your thanks for their hard work and dedication by clicking on the KUDOS button next to each of their posts below.

 

These are the instructions for getting Outlook, Outlook Express, and Windows Mail to work properly on your PC.

 

Also note the instructions further below for Mozzila’s Thunderbird and a link for Mac Configurations.

 

Also note the instructions further below for Mozzila’s Thunderbird,a link for Mac Configurations, and a link to download, install, and configure Windows LIVE Mail. 

 

NOTE:  You can no longer use Port 25 for SMTP  (Outgoing server)  You must use the settings listed here.

---------------------------------------------------------------------------------------------------------------------

Comcast supports Xfinity Connect webmail and industry standard POP3. For you, this means you can access your email on Xfinity Connect via a web browser from www.comcast.net , or you can use any of the large variety of pop clients available to you such as Outlook Express and Mac Mail.  

Comcast offers official support for Outlook Express 6.0 and higher, Windows Mail and Mac Mail. However, most pop3 clients will work with the Comcast email service.

---------------------------------------------------------------------------------------------------------------------------

Windows Mail, Windows Live Mail, Outlook Express & Outlook 2000:

  1. choose Tools
  2. choose Accounts
  3. go to the Mail tab
  4. click on your Comcast account to highlight it
  5. choose Properties
  6. go to the General tab
  7. under Mail Account, enter whatever you'd like to call this account, like John Doe on Comcast
  8. under User Information, enter Name (whatever you want to appear on your messages)
  9. enter E-mail address (your full Comcast email address)
  10. check "Include this account when receiving mail or synchronizing"
  11. go to the Servers tab
  12. "My incoming mail server is a" POP3 "server"
  13. Incoming mail is mail.comcast.net
  14. Outgoing mail is smtp.comcast.net
  15. enter your Account name or Email user name (your Comcast user ID, the part before "@comcast.net" in your email address)
  16. enter your Password
  17. check "Remember password"
  18. make sure “Logon using Secure Password Authentication (SPA)” is NOT checked
  19. check “My server requires authentication”
  20. choose Settings
  21. choose “Use same settings as my incoming mail server”
  22. click OK
  23. go to the Advanced tab
  24. check both boxes for “This server requires a secure connection (SSL)”
  25. change port number to 995 for incoming, 587 or 465 for outgoing
  26. bump up the Server Timeouts slider to the high end

 

Note:  With Windows Live Mail - Leave the box ticked which says, "clear text authentication"

 

Turn off whatever email scanning your anti-virus package is doing. Comcast already scans incoming email for viruses, and your outgoing email isn’t going to be infected unless your machine is already infected, so there’s no point checking it all the time.

--------------------------------------------------------------------------------------------

 

Outlook 2002 & Outlook 2003:

      1. choose Tools

2.choose E-mail Accounts

3.choose "View or change existing e-mail account"

4.choose Next

5. click on your Comcast account to highlight it

6.choose Change

7. enter Your Name (whatever you want to appear on your messages)

8. enter E-mail Address (your full Comcast email address)

9. Incoming mail server is mail.comcast.net

10.  Outgoing mail server is smtp.comcast.net

11.  enter User Name (your Comcast user ID, the part before "@comcast.net" in your email address)

12.  enter Password

13.  check "Remember password"

14.  make sure “Logon using Secure Password Authentication (SPA)” is NOT checked

15. choose More Settings

16.  go to the Outgoing Server tab

17.  check “My outgoing server (SMTP) requires authentication”

18.  choose “Use same settings as my incoming mail server”

19.  go to the Advanced tab

20.  check both boxes for “This server requires an SSL-secured connection”

21.  change port number to 995 for incoming, 587 or 465 for outgoing

22.  bump up the Server Timeouts slider to the high end

23. Click OK, Next, Finish

Turn off whatever email scanning your anti-virus package is doing. Comcast already scans incoming email for viruses, and your outgoing email isn’t going to be infected unless your machine is already infected, so there’s no point checking it all the time.

Don't bother with the "Test" function in Outlook - it often fails for no particular reason.

Exit from Outlook, then make sure it isn't still running in the background. Hit CTRL-ALT-DEL, go to the Processes tab, and kill any occurrences of OUTLOOK.EXE before launching Outlook again.

--------------------------------------------------------------------------------------------

Outlook 2007:

  1. choose Tools
  2. choose Account Settings
  3. choose the Email tab
  4. click on your Comcast account to highlight it
  5. choose Change
  6. enter Your Name (whatever you want to appear on your messages)
  7. enter E-mail Address (your full Comcast email address)
  8. choose POP3 as the Account Type
  9. Incoming mail server is mail.comcast.net
  10. Outgoing mail server is smtp.comcast.net
  11. enter User Name (your Comcast user ID, the part before "@comcast.net" in your email address)
  12. enter Password
  13. check "Remember password"
  14. make sure “Logon using Secure Password Authentication (SPA)” is NOT checked
  15. choose More Settings
  16. go to the Outgoing Server tab
  17. check “My outgoing server (SMTP) requires authentication”
  18. choose “Use same settings as my incoming mail server”
  19. go to the Advanced tab
  20. choose SSL encryption for both incoming and outgoing servers
  21. change port number to 995 for incoming, 587 or 465 for outgoing
  22. bump up the Server Timeouts slider to the high end
  23. Click OK, Next, Finish

Turn off whatever email scanning your anti-virus package is doing. Comcast already scans incoming email for viruses, and your outgoing email isn’t going to be infected unless your machine is already infected, so there’s no point checking it all the time.

-------------------------------------------------------------------------------------------------------------------------------------

 

Setting up Outlook 2010 for email

 

To set up a new email account: 


  1. Click the Office button located in the left most corner. Under the Info category you will see Account Settings. Click the drop down button and choose Add Account.



  2.  Check the Manually configure server settings or additional server types radio button and click Next.

  3. Select Internet Email then click Next.

  4. Fill in all fields for User, Server, and Logon information.
    Incoming mail server: mail.comcast.net
    Outgoing mail server: smtp.comcast.net
    Click the More Settings button


     

  5. In the Outgoing Server tab, check the box marked My outgoing server (SMTP) requires authentication and ensure the Use same settings as my incoming mail server is selected. 


     

  6. In the Advanced Tab change the Incoming Server (POP3) to port 110 and make sure the box next to 'This server requires an encrypted connection (SSL)' is NOT checked.  Change the Outgoing Server (SMTP) to port 587 and change 'Use this following type of encrypted connection'  to None then click OK

  7. Check the settings by clicking Test Account Settings on the Internet Email Settings screen.  When test completes click Close

  8. Click Next then click Finish

-------------------------------------------------------------------------------------------------------------------------------------

 

Mozilla’s Thunderbird Settings:

Outgoing Server (SMTP):
Settings
Description: Comcast
Server Name: smtp.comcast.net
Port: 587

Security and Authentication
Use name and password is checked
User name: your Comcast user name
Use secure authentication: left unchecked
Connection Security (pulldown): STARTTLS

Server Settings (these are the incoming settings)
Server Type: POP Mail Server
Server Name: mail.comcast.net
Port: 995
User name: your Comcast user name

Security settings section
Use secure connection: SSL button is selected
Use secure authentication: left unchecked

 

 

Mac Email Settings

 

10.5, 10.6]: Managing your Comcast email in Leopard, Snow Leopard, and previous versions of OS X:

 

This is a clickable link to the Macintosh Forum with detailed information about configuring your email using a Mac.

 

http://forums.comcast.net/t5/E-Mail-Help-Forum/Managing-your-Email-in-OSX/m-p/778503#U778503

 

 

 

Windows LIVE Mail

 

Please download attachment in post for offline viewing.

 

The Windows Live Mail link includes links to the download, as well as directions for configuring 'Windows Live Mail' which is different than the directions for configuring 'Windows mail'. 

 

 

 

 

The below is a graphical image of the email settings.

 

George Lunski
"Retired" Comcast Help Forums Administrator
Email Expert
CCCarole
Posts: 28,861
Registered: ‎05-21-2006

Re: E-Mail Client Settings (customer generated)

[ Edited ]

 


Welcome :smileyhappy:


Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




Mac Expert
Joel
Posts: 5,829
Registered: ‎12-01-2003

Re: E-Mail Client Settings (customer generated)

[ Edited ]

Welcome x 2 :smileyhappy:

Email Expert
JR071702
Posts: 6,888
Registered: ‎03-10-2004

Re: E-Mail Client Settings (customer generated)

[ Edited ]

Welcome x 3 :smileyhappy:

Email Expert
JR071702
Posts: 6,888
Registered: ‎03-10-2004

Re: E-Mail Client Settings (customer generated)

 

Mozilla Thunderbird Settings:

 

Please check your settings against what I list below - I use T-Bird and these settings work fine for me:

Also, please list any error messages that you are receiving.

 



JR

 

Official Employee
ComcastKen
Posts: 163
Registered: ‎10-05-2012

Re: E-Mail Client Settings (customer generated)

[ Edited ]

Eudora Setup for POP/IMAP


1) Choose your Profile Name

 

01.png

 

2) Choose your Profile Name

 

02.png

 

3) Type your Name

 

03.png

 

4) Put in your Comcast Email Address

 

04.png

 

5) Type in your User Name

 

05.png

 

6) Type in incoming mail server and choose email Protocol

 

06.png

 

7) Type in Outgoing email server: smtp.comcast.net

 

07.png

 

8) Finally, Click Finish

 

08.png

 

9) Eudora has chosen to hide the Port change option in version 6.0 and above, to enable changing ports:

 

1. Navigate to your Eudora install directory.

2. Look in the Eudora directory for the directory "extrastuff".

3. In this directory is a file named "esteric.epi". Drag (copy or move) this file into the main Eudora directory. There will now be options extra listed, including a Ports Page.

 

10) Launch Eudora and go to Tools->  Options menu and type in correct Ports for SMTP and POP (NOTE: IMAP port should be 995)

 

10.png

 

11) Scroll up on left menu to Checking Mail and choose “Required, Alternate Port” in drop down

 

11.png

 

12) Choose Sending Mail and do the same with drop menu, choose “Required, Alternate Port”

 

12.png

 

13) Now test out receiving and sending emails.  Make changes as necessary to your scenario.



 

Ken Tran
Comcast Silicon Valley