Welcome to Comcast Help & Support Forums
You can contribute an answer or post a question.
Reply
Posted by
Most Valued Poster
Member Since: ‎07-01-2005
Posts: 1,309

I can't send my Comcast email from my mobile...

Hi. I set up my Comcast email account on my Motorola Droid X and I receive my mail fine.
However, every time I try to send a message I get "Comcast message not sent: Authentication error sending." I compared the settings with those on my desktop and the only difference I can see is, on my computer the
outgoing server port is "0" and on the phone it's "587".

Does anyone have an idea how I can fix this problem?

 

br

Posted by
Networking Expert
Member Since: ‎07-28-2003
Posts: 24,238

Re: I can't send my Comcast email from my mobile...

0 is the WRONG port, 587 is CORRECT.  But when you use 587, you must have outgoing password authentication turned on as well, or it will fail with the kind of message you are seeing.  So turn that on and try again.

Posted by
Most Valued Poster
Member Since: ‎07-01-2005
Posts: 1,309

Re: I can't send my Comcast email from my mobile...

Hi Baric,

 

On my desktop I changed my port to 587 and my Authentication method to Encrypted password. Now when I try to send I get this: "Sending of message failed. The message could not be sent because the connection to SMTP server smtp.comcast.net timed out. Try again or contact your network administrator." I had no problem sending before.

 

On my phone I also changed my port to 587, checked "Use secure connection" and selected Use secure password (TLS): "Always" and I'm still getting the Authentication error.

 

What am I doing wrong?

 

br

Posted by
Networking Expert
Member Since: ‎07-28-2003
Posts: 24,238

Re: I can't send my Comcast email from my mobile...

What do you mean by "encrypted password"?  What email client are you using?  There are a number of different ways to do password authentication, if you pick one that is not support by Comcast, it won't work.  Use simple password, do NOT use Secure Password Authentication (SPA), that's a proprietary system from Microsoft and Comcast does not support it, nor does anyone else I am aware of.

 

Some phones you need to setup 587 with SSL, not TLS, on others TLS is the proper setting.  That is a way to secure the connection, but it doesn't do authentication in and of itself.  So you have to check the options for authentication as well.  I do not have your phone, so I can't provide the exact settings, just tell you what the server requires:

 

Server: smtp.comcast.net

Port: 587 with or without SSL/TLS

      465 with SSL

      25 with or without SSL/TLS

Authentication: Password with Comcast userid and password, required on 587 and 465, optional on port 25 (but recommended)

Posted by
Most Valued Poster
Member Since: ‎07-01-2005
Posts: 1,309

Re: I can't send my Comcast email from my mobile...

[ Edited ]

Okay, I have my desktop email working again, thanks. I'm using Thunderbird and under SMTP Server/ Security and Authentication are listed:
Connection security- options are "None", "STARTTLS" and "SSL/TLS". I selected "None".
Authentication method- I selected "Password, transmitted unsecurely" rather than "No authentication" and "Encrypted password".

 

I still can't get the doggone phone to send yet. Under Outgoing server I have "Use secure connection" unchecked. Under that "Use secure password (TLS)" has three options: Never, Auto and Always. I have Auto selected. Then, under "Authentication" the options are None, Auto and MD5. I selected Auto.

 

br

Posted by
Networking Expert
Member Since: ‎07-28-2003
Posts: 24,238

Re: I can't send my Comcast email from my mobile...

I would recommend STARTTLS with 587 in Thunderbird.  If not, data sent between you and the SMTP server are in plain text and anyone with the ability to sniff your packets can see your email.

 

And yes, "Password, transmitted unsecurely" is the right choice here,and since you have STARTTLS (right?) it's still encrypted.

 

As for the phone, try going to 465, Use secure connection is checked, and Never for TLS.  Under authentication, select Auto, MD5 does not work when connected using port 465.

Posted by
Most Valued Poster
Member Since: ‎07-01-2005
Posts: 1,309

Re: I can't send my Comcast email from my mobile...

Sometimes the simplest route is the most effective. While I greatly appreciate all the advice, none of it worked for me. I finally called Comcast tech support and the young lady recommended I remove the Comcast account from my phone and set it up again. Voila!

 

Thanks again, Baric, for the time and attention you devoted to my problem.

 

br

Posted by
New Visitor
Member Since: ‎09-01-2012
Posts: 2

Re: I can't send my Comcast email from my mobile...

I got a new Galaxy S3 phone and I have tried all the configurations to send email thru smtp.comcast.net and what ever port I use with what ever security i always get "server does not support authentication" My cell phone does not have a switch to select do not use authentication as does Outlook on my desk top. How can I get this to work on my Galaxy S3?.

Posted by
New Visitor
Member Since: ‎09-14-2012
Posts: 1

Re: I can't send my Comcast email from my mobile...

Thanks!  I had the same problem. Deleted and readded the account and it fixed my problem immediately. 

Advanced
You must be signed in to add attachments