Reply
New Visitor
Posts: 2
Registered: ‎01-06-2007

Outlook POP settings for comcast mail

I have not been successful in setting up Outlook on my local client to pull in Comcast mail (Adelphia worked) since my accts where moved over. I am using mail.comcast.net, port 110 for incoming and smtp.comcast.net, port 587 and requires authentication / use same settings as my incoming mail server for outgoing. When I run test acct settings from within outlook I get an "outlook can not connect to the outgoing mail server" error; however when I select send and receive from the outlook menu bar I do not get any errors (or mail).  If I log into Comcast web mail I have new mail; however, I have not been successful in pulling it in.  Thoughts?

 

Recognized Contributor
Posts: 14,085
Registered: ‎10-01-2003

Re: Outlook POP settings for comcast mail

First, are you using any incarnation of Norton Internet Security? If so, the Symantec/Norton folks have an article about problems like this, so their suggestions should be attempted first. They have a troubleshooting routine you can run from that webpage. If that fails, they suggest removing and reinstalling Norton. Personally, I'd skip the "reinstalling" part.

If you're using McAfee or Norton, disable the wormstopper or Internet worm protection in its email settings. It's been known to cause problems.

In Outlook 2002 & Outlook 2003:

  1. choose Tools
  2. choose E-mail Accounts
  3. choose "View or change existing e-mail account"
  4. choose Next
  5. click on your Comcast account to highlight it
  6. choose Change
  7. enter Your Name (whatever you want to appear on your messages)
  8. enter E-mail Address (your full Comcast email address)
  9. Incoming mail server is mail.comcast.net
  10. Outgoing mail server is smtp.comcast.net
  11. enter User Name (your Comcast user ID, the part before "@comcast.net" in your email address)
  12. enter Password
  13. check "Remember password"
  14. make sure “Logon using Secure Password Authentication (SPA)” is NOT checked
  15. choose More Settings
  16. go to the Outgoing Server tab
  17. check “My outgoing server (SMTP) requires authentication”
  18. choose “Use same settings as my incoming mail server”
  19. go to the Advanced tab
  20. check both boxes for “This server requires an SSL-secured connection”
  21. change port number to 465 for outgoing, 995 for incoming
  22. bump up the Server Timeouts slider to the high end
  23. Click OK, Next, Finish

Turn off whatever email scanning your anti-virus package is doing. Comcast already scans incoming email for viruses, and your outgoing email isn’t going to be infected unless your machine is already infected, so there’s no point checking it all the time.

On your firewall, make sure ports 465 and 995 aren’t blocked (if the software will let you do that).

Don't bother with the "Test" function in Outlook - it often fails for no particular reason.

Exit from Outlook, then make sure it isn't still running in the background. Hit CTRL-ALT-DEL, go to the Processes tab, and kill any occurrences of OUTLOOK.EXE before launching Outlook again.

New Visitor
Posts: 2
Registered: ‎01-06-2007

Re: Outlook POP settings for comcast mail

Thanks, worked perfectly.
Contributor
tillwoman
Posts: 11
Registered: ‎01-05-2007

Re: Outlook POP settings for comcast mail

Thanks very much, this helped me too. 

The port number settings you have here are different from the ones the Comcast FAQ said to use.  Theirs didn't work.   These do. 

Whee!  Email!

Contributor
dfens42
Posts: 19
Registered: ‎12-23-2006

Re: Outlook POP settings for comcast mail

The different port numbers have to do with the usage of the SSL sockets, I believe.
 
Recognized Contributor
Posts: 14,085
Registered: ‎10-01-2003

Re: Outlook POP settings for comcast mail



dfens42 wrote:
The different port numbers have to do with the usage of the SSL sockets, I believe.
 


Correct.  And for reasons not fully understood, using SSL and those alternate port numbers seems to get around a host of email problems, usually relating to firewalls and anti-virus packages.  It usually turns out to be easier to fix it that way than to go plunging into the innards of a bunch of third-party security packages!