Reply
Regular Visitor
Posts: 3
Registered: ‎12-09-2004

Sending emails on my 3gs iphone

Since syncing my 3gs iphone with Outlook 2007 I have been unable to send emails from the iphone using my Comcast account when wireless is off or unavailableI receive emails with no difficulty, and can send and receive messages on the iphone from my gmail accountHoweverif I try to send an email from my iphone using my  Comcast account, I receive the error message "the sender address 'djsilv@comcast.net' was rejected by the server. '"  Following the instructions posted for Outlook 2007SSL is on and the incoming  port is set to 995. I find no separate place to set an outgoing port.

Bronze Problem Solver
Posts: 3,263
Registered: ‎05-12-2006

Re: Sending emails on my 3gs iphone

 


djsilv wrote:

Since syncing my 3gs iphone with Outlook 2007 I have been unable to send emails from the iphone using my Comcast account when wireless is off or unavailableI receive emails with no difficulty, and can send and receive messages on the iphone from my gmail accountHoweverif I try to send an email from my iphone using my  Comcast account, I receive the error message "the sender address 'djsilv@comcast.net' was rejected by the server. '"  Following the instructions posted for Outlook 2007SSL is on and the incoming  port is set to 995. I find no separate place to set an outgoing port.


It looks like the SMTP port is OK. The problem is that you need to enable authentication for SMTP. I don't know how to do it on the iphone, but that's what you need to do. The sender address is being rejected because it was sent "early", the next step should be authentication. The response from the server is "550 5.1.0 Authentication required", but the iphone only tells you that the address wasn't accepted.

 

Regular Visitor
Posts: 3
Registered: ‎12-09-2004

Re: Sending emails on my 3gs iphone

Steve,

Thanks so much for your suggestion, but I see no place in the setup for a mail account for enabling authentication of STMP. 

Perhaps I haven't explained the problem correctly.  If wireless is enabled on my iphone and I am connected through Comcast or any other wireless outlet, I can send emails using my Comcast account. However, if wireless is not enabled, and I am using the AT&T wireless network the Comcast server rejects the email. However, I still receive emails from my Comcast account. This problem did not occur until I synced my iphone with Outlook 2007. 

Thank you.

Mac Expert
Joel
Posts: 5,829
Registered: ‎12-01-2003

Re: Sending emails on my 3gs iphone

I'm assuming you have a MobileMe account. What's supposed to happen when the iPhone syncs with the email client is that is also syncs its settings. Therefore, if you set the iPhone with the proper Port 587-SSL-Password Authentication setting and Outlook was set differently, the synching process changed the settings on the phone. Make sure that Outlook is set for SMTP port 587, enable SSL (or STARTTLS if its defined as such), and check off "this server requires authentication." Do NOT enable SPA or Secure Password Authentication. This is not supported. If you're unsure how to do this in Outlook, take a look at the post at the top of the Email forum entitled "Customer Generated FAQs" and look for setup info for your version of Outlook.

Bronze Problem Solver
Posts: 3,263
Registered: ‎05-12-2006

Re: Sending emails on my 3gs iphone

 


djsilv wrote:

Steve,

Thanks so much for your suggestion, but I see no place in the setup for a mail account for enabling authentication of STMP. 

Perhaps I haven't explained the problem correctly.  If wireless is enabled on my iphone and I am connected through Comcast or any other wireless outlet, I can send emails using my Comcast account. However, if wireless is not enabled, and I am using the AT&T wireless network the Comcast server rejects the email. However, I still receive emails from my Comcast account. This problem did not occur until I synced my iphone with Outlook 2007. 

Thank you.


 

That mostly makes sense. Sounds like the iphone and Outlook are both configured to use port 25. Authentication isn't required on port 25 when you're hooked up to the Internet via Comcast, but it is required when you connect to the Comcast SMTP servers from outside of Comcast (like from ATT).

 

One thing that doesn't make sense is "any other wireless outlet"... unless all those other wireless outlets have Comcast connectivity. The other thing that doesn't make sense is that I though that ATT blocked outgoing port 25 connections, which means that you wouldn't even be able to reach the Comcast servers on port 25 via ATT, let alone have authentication problems.

 

Hmm. How consistently have you had this problem, like, how many tests have you done? When I checked, Comcast recognized your address as a valid Comcast address, but sometimes Comcast has problems with that. It's remotely possible that there was a glitch with Comcast such that you *were* authenticating successfully, but that, after authenticating, Comcast didn't recognize your email address as valid. That would mean that Comcast uses different validity checks for the authentication process than it uses for checking address validity, but, who know? That's pretty unlikely... I'm thinking about just deleting this paragraph, but what the heck, I'll leave it.

 

Anyway, whatever the situation, port 587 is a better choice than port 25 for an number of reasons, so I think you should do what Joel suggested: start over, set up Outlook for port 587, and resynch.