Reply
Visitor
Posts: 2
Registered: ‎10-08-2005
Accepted Solution

iphone email

I can receive mail but cannot send on my IPhone...a message keeps popping up saying "the sender address was invalid"
Networking Expert
Baric
Posts: 24,238
Registered: ‎07-28-2003

Re: iphone email

I suspect that the Address you have configured for your default Account is mispelled somehow and is not a valid email address.  To correct:

  1. Go to Settings -> Mail, Contacts, Calendars
  2. Select your default account from the Accounts list
  3. Verify your Address under POP Account Information.  Check for misspellings, missing domain name, spaces, and other invalid characters

 

Official Employee
charvey
Posts: 1,662
Registered: ‎07-09-2008

Re: iphone email

[ Edited ]

Configuring your iPhone for Comcast.net email

If this is the first mail account you're setting up on your iPhone, tap Mail. Otherwise, from the Home screen, choose Settings > Mail > Account > Add Account.

  1. When asked to choose your e-mail account type, choose Other.
  2. Fill in your name, then your entire comcast.net e-mail address (johnsmith@comcast.net) and password. You can also change your description of the account to identify the Comcast account amongst any others you might have.
  3. The iPhone will then check and auto-configure itself for sending and receiving.
  4. If this auto-configure doesn't work use the following settings.
    1. Incoming Mail Server is mail.comcast.net
    2. User name is just the first part of your address (johnsmith)
    3. Password is the correct password for that specific account
    4. Outgoing Mail Server is smtp.comcast.net
      1. Advanced:
      2. Use SSL ON
      3. Authentication: Password
      4. Delete from server based on your preferences
      5. Server port 995

Message Edited by charvey on 03-30-2009 01:18 PM
New Visitor
Posts: 1
Registered: ‎01-24-2009

Re: iphone email

Have you resolved this yet? I have the same problem -- occured when comcast implemented SmartZone. Comcast help operators are no help at all. I have messages sitting in iphone outbox and get message "sender address is invalid".
Official Employee
charvey
Posts: 1,662
Registered: ‎07-09-2008

Re: iphone email

Did you follow the instructions carefully on the post above yours?
Networking Expert
Baric
Posts: 24,238
Registered: ‎07-28-2003

Re: iphone email

The email address you have configured for the account you are using to send is invalid.  Go to Settings -> Mail, Contacts, Calendars and tap the account you are using to send.  In the POP Account information section, correct the Address field to your complete email address, for example StevieM@comcast.net.  Be careful of mispellings, invalid domain names, missing "@", invalid characters (like spaces), etc.
Visitor
Posts: 4
Registered: ‎03-07-2009

Re: iphone email

I'm having same problem. Did you get a solution
Email Expert
JR071702
Posts: 6,888
Registered: ‎03-10-2004

Re: iphone email


gramps49 wrote:
I'm having same problem. Did you get a solution

Did you read any/all of the suggestions below the OPs and try those??
JR

Visitor
Posts: 4
Registered: ‎03-07-2009

Re: iphone email

Yes, I did. I even created a test account on my desktop to test sending/receiving then used iTunes to sync new account to iPhone. I'm still having the problem.
Networking Expert
Baric
Posts: 24,238
Registered: ‎07-28-2003

Re: iphone email

What settings are you using, exactly?  Getting any errors?  I can say my iPhone works just fine with my Comcast email account(s) as long as I configure it properly.
Visitor
Posts: 4
Registered: ‎03-07-2009

Re: iphone email

My 1st iPhone 3G worked just fine with my Comcast email account too but the phone failed on making calls and was replace about a month ago. I didn't notice the email failure with my current iPhone until last week because most of my keyed communication is via SMS.

 

Here are my settings:

 

POP Account

Name:   Username

Address:   username@comcast.net

Description: username@comcast.net

 

Incoming Mail Server

Host Name: mail.comcast.net

User Name: Username

Password: .............

 

Outgoing Mail Server

SMTP: smtp.comcast.net

Host Name: smtp.comcast.net

User Name: Optional

Password: Optional

Use SSL: Off

Authentication: Password

Server  Port: 587  

Networking Expert
Baric
Posts: 24,238
Registered: ‎07-28-2003

Re: iphone email

You still don't say what's failing.  We can't read your mind.  What doesn't work?  Sending a message?  Receiving new email?  what error are you getting?

 

That said, your settings are incorrect for Outgoing.  When usng port 587, username and password are REQUIRED, not Optional. So specify your Comcast userid and password here.  I would also recommend turning on SSL, it's a good security precaution. 

Visitor
Posts: 4
Registered: ‎03-07-2009

Re: iphone email

I'm sorry for not being specific. I thought the 1st and 4th post to this thread were defining the the subject matter. I can now send emails from my iPhone. Thanks for your assistance.
New Visitor
New Visitor
Posts: 1
Registered: ‎03-16-2009

Re: iphone email: outgoing mail not sent

I had the same problem until I fixed it based on the information in this thread.    The username and password box was grayed out and I didn't think I could enter the data so skipped those boxes.  wrong move - have to input username and password.
Visitor
Posts: 3
Registered: ‎03-29-2009

Re: iphone email

HI,

How do I know which server port to use?  I had a different one... and when I changed it to 995 - I still am getting the "sender address is invalid"  I have deleted the account and re-set it up a few times. 

I have two accounts on my iPhone - both comcast.net accounts

One I check on the web only - can send email

the other I use outlook express on my pc - get the error "sender address is invalid".

 

any ideas?

 

thanks!

 

Regular Visitor
Posts: 2
Registered: ‎05-27-2005

Re: iphone email: outgoing mail not sent

Thanks for the tip about entering the username and password in the outgoing mail server section.  I can finally send mail via comcast using my ipone!
Bronze Problem Solver
Posts: 3,263
Registered: ‎05-12-2006

Re: iphone email


charvey wrote:

Configuring your iPhone for Comcast.net email

...

    1. Outgoing Mail Server is smtp.comcast.net
      1. Advanced:
      2. Use SSL ON
      3. Authentication: Password
      4. Delete from server based on your preferences
      5. Server port 995

Whoops, port 995 is for incoming. You probably meant port 465.

Bronze Problem Solver
Posts: 3,263
Registered: ‎05-12-2006

Re: iphone email


stephanieD wrote:

HI,

How do I know which server port to use?  I had a different one... and when I changed it to 995 - I still am getting the "sender address is invalid"  I have deleted the account and re-set it up a few times.

I have two accounts on my iPhone - both comcast.net accounts

One I check on the web only - can send email

the other I use outlook express on my pc - get the error "sender address is invalid".

 


Charvey made a mistake, port 995 is for incoming email, not outgoing. Here are the port variations for Comcast email:

 

POP

110

995 requires SSL.

 

SMTP

25- authentication required from outside of Comcast. TLS optional.

587- authentication required. TLS optional.

465- authentication required. SSL required.

 

Note that SPA (Secure Password Authentication) is not supported by Comcast, the authentication option that's required is usually something like a checkbox labeled "My server requires authentication)

 

"sender address is invalid" sounds like an impossible error to get if you're trying to send email via connecting to the SMTP servers on port 995, but maybe that's a matter of a goofy email client error message. Or maybe it's about some confusion about your configuration. Comcast requires that the domain part of the sender email address is a valid email domain. What's the domain part of your sender email address?

Visitor
Posts: 3
Registered: ‎03-29-2009

Re: iphone email

Thanks for your answer - to answer your question
I have tried numerous email domains:  including comcast.net; examples - msn.com,yahoo.com,verizon.net

- I can successfully send the same emails from the 2nd comcast account (the one I check from the web only)

- I can receive on my primary account that is downloaded to Outlook express as well as the new Iphone, but I can't send any emails from the IPhone for this account.  I continue to get the "sender address is invalid".

 

I checked the setting in my outlook express and it says my outgoing email should be on port 25 on the SMTP setting - but I don't see where I change that on the IPhone - I can only change the port on the incoming settings in the advanced settings in the set up menu.

 

I have deleted and re-set this account three times... am getting very frustrated.  And of course, my husband is laughing because he has a Blackberry!  I just tried again and get the same message:

cannot send mail

the sender address was invalid

- and I was sending it to a comcast email address.

 

any ideas... help.....

thanks

Bronze Problem Solver
Posts: 3,263
Registered: ‎05-12-2006

Re: iphone email


stephanieD wrote:

Thanks for your answer - to answer your question
I have tried numerous email domains:  including comcast.net; examples - msn.com,yahoo.com,verizon.net

- I can successfully send the same emails from the 2nd comcast account (the one I check from the web only)

- I can receive on my primary account that is downloaded to Outlook express as well as the new Iphone, but I can't send any emails from the IPhone for this account.  I continue to get the "sender address is invalid".

 

I checked the setting in my outlook express and it says my outgoing email should be on port 25 on the SMTP setting - but I don't see where I change that on the IPhone - I can only change the port on the incoming settings in the advanced settings in the set up menu.

 

I have deleted and re-set this account three times... am getting very frustrated.  And of course, my husband is laughing because he has a Blackberry!  I just tried again and get the same message:

cannot send mail

the sender address was invalid

- and I was sending it to a comcast email address.


To clarify, the "sender address" isn't the email address that you're trying to send the email to, it's the address you use as your From address. Comcast requires that that address have a valid email domain in the domain part of the email address. That's the domain I'd like to see for the setup that's giving you trouble, it sounds like there's a typo or a problem with the domain that's causing your trouble. And (just FYI) if the sender address is user@comcast.net, Comcast requires that "user" be a valid Comcast account... but that generates a different error message than the one you're seeing.

 

I don't know anything about the Iphone, how to configure it, how it's hooked up to the Internet, none of that, I just know how the Comcast email servers work. But I'll mention that using port 25 under any circumstances is precarious. Comcast could block your port 25 (as a Comcast user) at any time, and when you're "traveling", *many" ISPs block port 25. Ports 587 and 465 are your best bets for maximum compatibility, but there just isn't a "one size fits all" configuration option guaranteed to work under all circumstances. FWIW.

Official Employee
charvey
Posts: 1,662
Registered: ‎07-09-2008

Re: iphone email


stephanieD wrote:

I checked the setting in my outlook express and it says my outgoing email should be on port 25 on the SMTP setting - but I don't see where I change that on the IPhone - I can only change the port on the incoming settings in the advanced settings in the set up menu.

 

any ideas... help.....

thanks


You can't use port 25 from the iPhone because its connecting via the ATT network and not the Comcast network. So, you either need to use port 587 or 465 and give your comcast.net credentials (username & password).

 

To configure the outbound connection go to Settings then Mail,Contacts,Calendars. Then select your comcast profile and scroll up to Outgoing Mail Server. In this screen select the comcast server and you'll see the port number at the bottom.

 

Also, check out this post for more instructions.

 

Visitor
Posts: 3
Registered: ‎03-29-2009

Re: iphone email

Thank you thank you... it works!

 

your comments were concise so a non-techie could follow the directions!  

New Visitor
Posts: 1
Registered: ‎07-09-2009

Re: iphone email

[ Edited ]

I have the same thing.  Sender address invalid.

Receiving is always fine

 

BUT IT WORKS (sends) WHEN I'M CONNECTED TO MY HOME WIFI NETWORK!!!

It only gives me this when I'm connected to another wifi network or 3g.

 

 

All my settings look good when compared to the posts above, it has addresses, passwords, etc.

What should the port be?

It was 110. 965, 465, 587 all give the same thing.

 

Please help, this makes sending mail unacceptable if I can only send it from home...

 

Thanks.

Message Edited by YOYODADDYO on 07-09-2009 09:59 AM
Bronze Problem Solver
Posts: 3,263
Registered: ‎05-12-2006

Re: iphone email


YOYODADDYO wrote:

I have the same thing.  Sender address invalid.

Receiving is always fine

 

BUT IT WORKS (sends) WHEN I'M CONNECTED TO MY HOME WIFI NETWORK!!!

It only gives me this when I'm connected to another wifi network or 3g.

 

 

All my settings look good when compared to the posts above, it has addresses, passwords, etc.

What should the port be?

It was 110. 965, 465, 587 all give the same thing.



It sounds like your problem is that you're using port 25 and authentication isn't enabled. When you connect from inside of Comcast you don't need to authenticate on port 25, but you do when you connect from outside of Comcast. And you always need to authenticate when using ports 587 or 465. Your best bet would probably be to use port 465 for sending (SMTP), with authentication (NOT Secure Password Authentication) enabled, and SSL enabled. For receiving (POP), use port 995 with SSL enabled.

I think all the problems with "Sender address invalid" are actually about "authentication required". The client isn't showing the actual error message, it's interpreting it based on the error code returned by Comcast. And Comcast is, I think, returning the wrong error code. It returns the same error code for a bad address as it does for "authentication required". EG:

550 5.1.0 Authentication required
550 5.1.0 Not our Customer
550 5.1.0 <c@adsf.cdf> sender rejected : invalid sender domain

I think they should probably be returning a 553 rather than a 550 for "authentication required".

Visitor
Visitor
Posts: 1
Registered: ‎03-07-2009

Re: iphone email

Appreciate the help with the necessity of adding the username and password on the outgoing settings.  y email works great now!

 

Thanks,

Frank

Networking Expert
Baric
Posts: 24,238
Registered: ‎07-28-2003

Re: iphone email

[ Edited ]

One thing I noted on my iPhone today is if you change the mail settings, it can fail to connect from then on, even though the settings are correct.  I'm not sure what causes this, but if you are sure you have the proper settings, then try powering off and restarting.  That clears up whatever the problem was and the iPhone starts connecting.  I have an 32GB iPhone 3GS running the latest version, YMMV on other models. To power cycle your iPhone, press and hold the Power button for a few seconds until you get a screen with a slider that says "slide to power off".  Move the slider to the right and the iPhone will shutdown.  When it's off, press and hold the Power button until it restarts.

 

The best settings to use are:

 

Incoming POP Settings - mail.comcast.net

 

 

Outgoing SMTP settings - smtp.comcast.net

 

 

EDIT: Corrections to power off sequence and a typo. 

Message Edited by Baric on 09-05-2009 12:20 PM
Official Employee
charvey
Posts: 1,662
Registered: ‎07-09-2008

Re: iphone email

Baric, to power cycle the phone, you just need to press and hold the top button, no need for a two button press. I also hope you meant 32Gb, or you were short-changed!
Networking Expert
Baric
Posts: 24,238
Registered: ‎07-28-2003

Re: iphone email

Chris, you're right! I got that information off a web site a long time ago, and since it worked, I never questioned it.  Yes, pressing and holding only the Power button for about 4 or 5 seconds brings up the power off slider.  Thanks for the correction.

 

And yes, 32GB, sometimes my fingers type something other than what I'm thinking... 

New Visitor
Posts: 1
Registered: ‎09-28-2009

Re: iphone email

Thank you.  This worked for me as well.  The tech support at Comcast by phone was useless.  Thank you for this forum. 
New Visitor
framefive
Posts: 1
Registered: ‎06-07-2011

Re: iphone email

Here's a little thing that worked fro me.  Iw as getting the "Invalid Address" message.  I went over the settings over and over again as I read this page.  But I noticed in the outgoing server settings, Authentication.  I would select the arrow to see the settings and I noticed that password was checked.  Thinking all was well. I moved on,.  But in one of the screen captures above I saw that on the actual outgoing server settings page, that the word Password was also shown there.  I looked at my selection, and sure enough password was checked,  I tried selecting one of the other choices (NTLM), then selected Password again.  I then went back to the outgoing server settings page, and lo-and-behold the word password was shown next to the authentication.  Now everything works great!

New Visitor
SalukiDad
Posts: 2
Registered: ‎04-06-2011

Re: iphone email

When I delete Comcast e-mail messages from my iPhone, they are still there when I check e-mail from my laptop going directly to Comcast website.  An IT person at my work says I need to set the iPhone to IMAP rather than POP.  But ALL the instructions I have read on this discussion and others say the POP setting is what to go with.  Who's right?  Another thought I had was that I think there is a setting on the iPhone called "Delete from Server".  Could that be the issue?  How do I make it so messages I delete from the iPhone also delete from the Comcast website? 

Email Expert
CCCarole
Posts: 28,884
Registered: ‎05-21-2006

Re: iphone email

Hopefully on the Mac Experts will see your post and reply.  Have you already checked through threads regarding this problem in the Mac Forum?  > LINK

 

Comcast email uses POP, not iMap.

CC

 



Need Email Help? Please post the following information in your post.
Do you use XfinityConnect? The Full or Lite version?
Do you use an email client? Which one? (Eg; Windows Live mail, Outlook, a smartphone etc.)
Which browser/version do you use? And- have you cleared your browser cache?
Which operating system? XP, Vista, Windows 7, Mac OS X
Details of the problem you are having.




New Visitor
SalukiDad
Posts: 2
Registered: ‎04-06-2011

Re: iphone email

I'm sorry, I misstated the problem.  When I delete messages on the comcast website from my laptop (which is a PC), they are still there on my iphone.  My IT friend says that's because POP downloads the messages to the iPhone and he says that IMAP shows messages on the Comcast server so they don't show on the iPhoneif they are deleted from any computer.  Are you sure IMAP doesn't work for Comcast?  In any event, is this an unsolvable problem that e-mail messages delete from the Comcast website have to be deleted again from the iPhone?  Why don't they delete from the iPhone when deleted from Comcast using a laptop?  Thanks in advance.

Email Expert
JR071702
Posts: 6,888
Registered: ‎03-10-2004

Re: iphone email

Comcast does not support the IMAP e-mail protocol at this time.

 

It is unknown whether they will support it in the future or not.

 

JR

New Visitor
mnpd3
Posts: 1
Registered: ‎08-17-2011

Re: iphone email

That is exactly the problem with sending mail on the Iphone.... if you make any changes, you must do a cold restart of the phone.  It's very annoying when everything is filled out correctly but the thing won't work.  All i did was change my email password, which led to a week of struggling and cussin' because I couldn't send mail.

Networking Expert
Baric
Posts: 24,238
Registered: ‎07-28-2003

Re: iphone email

[ Edited ]

mnpd3 wrote:

That is exactly the problem with sending mail on the Iphone.... if you make any changes, you must do a cold restart of the phone.  It's very annoying when everything is filled out correctly but the thing won't work.  All i did was change my email password, which led to a week of struggling and cussin' because I couldn't send mail.


This has been an intermittent issue with the iOS Mail client for a long time.  I have not seen it recently, but it used to be if you made change to ports, servers, etc, you have to reboot the phone sometimes to pick up the changes.  Nothing to do with Comcast, though.  Since I have not seen it in a long time, I had assumed the problem havd been fixed in some iOS update along the way.  What version of iOS are you running?  Have you updated it recently?  I know some folks get their phone and then never, ever sync and update.  It is something you should do once every month or two if for no other reason than to get updates. I think iOS 4.3 is the latest version, although I will have to check to be sure (don't have my iPhone or iPad handy at the moment).

 

EDIT: Latest is iOS 4.3.5 ;-)

New Visitor
Posts: 1
Registered: ‎09-23-2009

Re: iphone email

Is this still accurate now that it has been almost 3 years?  Especially the port info, I thought it was suppose to be either 110 or 587?

 

I am not receiving my email comcast messages from my comcast account into my iphone. I think there is a setting that will automatically delete messages in my Comcast account once they are sent to my Outlook account and this is prohibiting them from then being available for my iphone 4 to retrieve them because it believes the inbox is emplty. My email messages are indeed arriving in my outlook so how do I confirgure all this. I am essentially looking at my email from 3 places; Comcast, Outlook and my iphone 4. Help!

 

Also, do we need to use the Comcast/Xfinity application for any of this or is that different?

 

Thanks,

Networking Expert
Baric
Posts: 24,238
Registered: ‎07-28-2003

Re: iphone email

In Outlook, go into your account settings and at the bottom of the Advanced tab, there is an option that says Leave a copy of messages on the server, make sure that is CHECKED.  that should prevent Outlook from deleting the messages after it downloads them, so you cen get them on your iPhone as well.

 

AS for ports, they have not changed.  I recommend port 995 with SSL for incoming messages, but 110 without SSL works fine as well.  For outgoing SMTP messages, use port 587 with SSL and password authentication.  Port 465 with SSL also works, as does port 25 without SSL.  Certain other combinations work as well, but I'd stick with 995 and 587, respectively.

 

If by Comcast/Xfinity appliction your mean Xfinity Connect, the answer is no, there is no reason to use it at all, except for occasional use when you are away from your computer, or for testing, etc.  it's entirely up to you if you want to use it, however.

New Visitor
Posts: 1
Registered: ‎05-29-2008

Re: iphone email

AHHHH!!! At last, I deleted email account and put it back in and now it works fine!!

What a pain! Again, Thanks Comcast for the MANY MANY problems.

Web Page Expert
BethKatz
Posts: 6,196
Registered: ‎11-14-2006

Re: iphone email

If you recently upgraded your iPhone to iOS 5, the upgrade process wiped your phone's memory and may have reinstalled settings from a previous backup rather than your current settings. That is an Apple problem in the upgrade. Comcast has many problems, but that isn't one of them.

 

If you upgraded and your mail isn't working, check that your settings match the ones in this post (click link). Be sure to save the settings.

Visitor
Posts: 4
Registered: ‎05-29-2008

Re: iphone email with POP comcast account

 Hi, I updated the iPhone 4 a month ago, and haven't since been able to send email.

 

Today, Verizon support, tier 2 provided great service after comcast gave up and told me to download Xfinity Connect, their email app.  It stinks.  don't bother.

 

turns out it was easy to fix after 30 minutes online with Verizon.

 

in the end, we deleted the email account on the iphone and re-entered all the data for the incoming and outgoing servers.  My ports had been reset apparently.  there is also a imap vs POP option when setting up the email account.  For Comcast, you must choose POP option, then enter the port information.  Call comcast for their info...

 

incoming server is

mail.comcast.net

port is 110    .......for me here in the midwest  (the 995 was there previously)

 

oh, and shut off the SSL setting.....on both incoming and outgoing servers!!!!!!!

 

outgoing server is

smtp.comcast.net

port is 25''


 

baddabing, badda boom.  it worked.  hope you have success.  if you don't, call verizon and make sure you get to talk to someone in tier 2 support.  they are much more knowledgeable.

 

good luck!

Web Page Expert
BethKatz
Posts: 6,196
Registered: ‎11-14-2006

Re: iphone email

Using port 25 as your outgoing server may not work. Comcast sometimes blocks it. It's great that it works for you now, but it might stop working - abruptly.

It's more secure to use the secure ports, SSL, and password authentication.

Any time you change your email settings on an Apple product, be sure to set both the incoming and outgoing ports and password. Password goes in two places. And it must be POP not IMAP.

Correct settings are shown in the posts at the top of this forum.
New Visitor
aantoniolo
Posts: 2
Registered: ‎01-09-2012

Re: iphone email

I have an iPhone 4 and am not able to send emails. I can receive emails but not send emails. I did not have this problem before (I had my phone since August 2011). On 1/7/2012 I ran the update from Apple, and that is when the problems started.

 

 

New Visitor
aantoniolo
Posts: 2
Registered: ‎01-09-2012

Re: iphone email

Hi, can you share the solution with me? I purchased my iPhone 4 in August, and everything was fine. On 1/7 I ran the update program and now I am having so many problems, it isn't even funny. One major problem is that my phone will receive emails, but not send them.

 

My phone book lost many phone numbers and addresses as well as email addresses. I wish I never updated my phone.

 

Anne-Marie

Web Page Expert
BethKatz
Posts: 6,196
Registered: ‎11-14-2006

Re: iphone email

As I wrote above, the update to iOS 5 does not save your mail files and may restore an old backup of your settings. Carefully check your phone settings with the ones in the pictures I posted here in another thread in this forum. In particular, you must set the password in two places - for both incoming and outgoing. I'm not going to post the pictures in every thread.

 

Since many people lose all their mail files in this upgrade, they don't feel they are losing much by deleting the account and creating it again.

 

Remember that the Comcast server does POP. It does not do IMAP.

Visitor
Posts: 4
Registered: ‎05-29-2008

Re: iphone email

Hi, I did the same thing.  very parallel paths.  I bought in July, updated the iPhone 4 software right before xmas.  bad move.  lost all emails on iPhone.  Many contacts reloaded from Verizon backup from their website.  many no longer used contacts, or multiple contacts were loaded into the phone.  ug.  what a pain.  but at least they're in there.  it's a free option with Verizon, but I recall you have to go to their website to enable backup.

 

I use MS Outlook for email here on the PC.  In Outlook, there is a setting to "keep a copy on server".  so in addition to the iPhone losing all emails, I forgot to mention my motherboard died right before xmas and had to rebuild it.  Luckily, 2500 emails were "on the server" with Comcast, esp ones from my sibling with her cancer fight.  so do that also.

 

back to the phone, the Verizon tier 2 tech and I figured out we should delete the whole email account in the iPhone 4.  when setting up the new account, there is an option that the Verizon guy at the mall must have configured, and that was to choose POP instead of imap.  do that, and enter your email, password, and username.  then, even though iPhone said a 2nd username and password were "optional" and grayed out....it wasnt!!   Not until I entered the username and password in 2 locatioins during email account setup, did it work!!!  Comon Apple!  get it together.

 

I have seen different port settings posted.  What worked for me is two things.  

1)  do not use SSL on incoming or outgoing servers.

 2) the port setting for incoming was changed to 110, and outgoing should be 95.

 

I then power cycled the iPhone and even the touch screen is working better.  now when I press END on a call, it quickly exits instead of having to press several times.

 

good times.  Hope this helps. 

Web Page Expert
BethKatz
Posts: 6,196
Registered: ‎11-14-2006

Re: iphone email

Although I understand that smackin10's settings may work for him, I strongly encourage you to turn on SSL and use password authentication. Comcast sometimes abruptly blocks port 25.


You need to set the password and ports in two locations - once for incoming and once for outgoing. This applies to iOS as well as Mac OS X for the built-in email clients.

 

POP server (not IMAP)

 

incoming settings

server: mail.comcast.net

port: 995

use SSL: checked

authentication: password

 

outgoing settings

server: smtp.comcast.net

port: 465 or 587   (NOT 25 and not the default that may roll to 25; )

use SSL: checked

authentication: password

 

New Visitor
ADTDan
Posts: 3
Registered: ‎01-12-2012

IOS 5 Iphone 4 email Settings for COMCAST and AT&T Iphone 4.

[ Edited ]

IOS 5 Iphone 4 email Settings for COMCAST & AT&T.

Provided by Daniel.mcmillen@comcast.net

 

If you recently (Dec 2011-Jan 2012) upgraded your iPhone 4 to iOS 5, the upgrade process wiped your phone's memory and may have reinstalled settings from a previous backup rather than your current settings.  My wife has an Iphone 4s (purchased in the fall of 2011) that I updated to IOS 5 about the same time, and did not have the problem.  That is an Apple problem in the upgrade.  Comcast has many problems, but that isn't one of them.  The Specific Error Message I received was:

 

cannot send mail

the sender address was invalid

 

I suggest that the phone be turned off by holding the button on the top of the phone down until you get the slider bar that says “Slide to power off”

 

I tried to reset the ports, but ended up not getting any email for about 4 days.  Based on info in this chain, I deleted the “comcast” email account on the iphone and re-entered all the data for the incoming and outgoing servers.  This does nothing to the contacts.  Beleow are all the setting for the Iphone4 with IOS 5.

 

Name:                                                    Your Name

Address:                                                yourusername@comcast.net

Password:                                              [Yourpassword]

Description:                                          Comcast

 

Incoming Mail Server settings

Host Name:                                           mail.comcast.net

User name:                                           [your Comcast user name]

Password:                                              [Yourpassword]

 

Outgoing Mail Server settings

Primary server:                    smtp.comcast.net

Server:                                 On

Host name:                          smtp.comcast.net

User name:                          [your Comcast user name]

Password:                            [Yourpassword]

use SSL:                                On

Authentication:                     Password

Server Port:                          465

Other SMTP Servers:            smtp.comcast.net

Server:                                  On

Host name:                          smtp.comcast.net

User name:                          [your Comcast user name]

Password:                            [Yourpassword]

use SSL:                               On

Authentication:                   Password

Server Port:                         587

 

Advanced Settings:

Deleted Messages:

Remove after:                       After one Week

Incoming Settings:

Use SSL:                                On

Authentication:                     Password

Delete from Server:              Never

Server Port:                           995

S/MIME:                                Off

 

Mail Contacts, calendar page

Mail

Default Account:                  [Comcast] or [iCloud]

Contacts

Sort Order:                            Either First, Last or Last, First

Display Order:                      Either First, Last or Last, First

My Info:                                [Pick your name from the contacts list]

Default Account:                  [From My PC] or [iCloud]

Visitor
Posts: 4
Registered: ‎05-29-2008

Re: IOS 5 Iphone 4 email Settings for COMCAST.

Hi all, in all earnest, I tried to follow your advice.  it didn't work for me.  

 

what works for me is the 110 and 25.  no ssl.   not sure why it doesn't work, but these are the settings Verizon gave me...and it works.   so good luck....

 

New Visitor
ADTDan
Posts: 3
Registered: ‎01-12-2012

Re: IOS 5 Iphone 4 email Settings for COMCAST.

[ Edited ]

I should have posted that I have an ATT Iphone 4.  Maybe the settings that Verizon uses are different.  I went back and changed the original Message to reflect that.