Reply
New Visitor
Dianexalice
Posts: 3
Registered: ‎05-13-2013

Arris TG 862 modem/router and problem with air print

I have 2 HP wireless / eprint printers. One is the HP Deskjet 3052a and the other is the HP Photosmart 5520. Both are connected to the wireless network and both will print from my HP Laptop and my Samsung notepad.
My ipad with print to the HP Deskjet 3952a but it will not print to the HP Photosmart 5520.
When the HP Photosmart is connected to the wireless network at the local apple store it will print from my ipad. The technician at the apple store informed me that the Arris TG 862 router is the problem, in that it does not support "bonjour". I am a little confused because I have 2 HP printers connected to the wireless network via the Arris TG 862 router. The HP deskjet will print from my ipad but the HP Photosmart will not.
Has anyone else had this problem. I would really appreciate some help with this.





Contributor
mamalloy
Posts: 5
Registered: ‎06-16-2013

Re: Arris TG 862 modem/router and problem with air print

Hi, I have been having a very similar problem with the Comcast-provided Arris device + HP Photosmart 5520 + iPhone or iPad...I have spent so many hours reading device manuals, and re-doing settings, and trawling other forums...but I've finally got mine working (knock on wood).  I will share one workaround and three alternative solutions that others have been successful with.  Oddly, not all solutions work for everyone, so I can only suppose this depends on their Comcast region or some other factors.

 

But the Apple tech was correct...the problem appears to be with this arris device.  What the communitiees say is that this device is not bonjour enabled...that is the protocol that must be used between iDevices + Airprint enabled printers. Also, in general, the real geeks say these combo devices where you have the cable and router and phone all-in-one (AIO) are notoriously bad... but that's a different issue.

 

I will provide the rest of my reply in separate posts because the explanations can get a little long. 

Contributor
mamalloy
Posts: 5
Registered: ‎06-16-2013

Re: Arris TG 862 modem/router and problem with air print

First, the workaround.  Have you set up ePrint for your Photosmart?  This allows you to email jobs to the printer.  

 

If you haven't done this already, it's very easy.  Just run the HP Printer Assistant (that would have been installed when you installed the printer on your home network)...it's a shortcut on your desktop or you can access it via Start >> All Programs >> HP >> HP Photosmart 5520 series.  You'll see the selection to set up ePrint.  Be sure NOT to enable secuity or the auto-off features...you can also check those once you've got your ePrinting set up by launching the ePrint setup again and clicking on the "Settings" tab.

 

You'll end up with an email address for your printer of your own choosing at hpeprint.com...like Dianexalice-5520@hpeprint.com.  This won't suit all your needs, but at least if you have a document or some selection you want to print out, you can attach the former or copy/paste the latter into an email that you send to your printer's address at hpeprint.com.

 

In the next post, I'll explain the first real solution that works for some people. 

Contributor
mamalloy
Posts: 5
Registered: ‎06-16-2013

Re: Arris TG 862 modem/router and problem with air print

Solution 1:  Some people are able to reboot the components and get the iDevice - printer communication going.  To do this, you need to power off your iPad / iPhone, pull the power plug out of the back of your printer, then do a hard reset on the Arris.  You have to do a hard reset because the Arris has a battery backup, so pulling the plug won't actually let you cycle the power.  Instead, get something pointy (rubber-coated paperclick is idea).  Look at the front panel of the Arris and be sure you could recognize which lights should be on steady, off or blinking.  For example, if you don't have phone service thru Comcast, then the lights labeled "Tel1" and "Tel2" will be off.  Next, go to the back panel and you'll see a tiny hole near to top labeled Reset.  Now, make sure you can see the lights on the front panel while you're doing this next step.  Press the point of the paperclip into that little hole and the lights go out on the front of the Arris, then remove it.  ATTENTION>> this only takes a second or two of pressure...you do not want to hold it in there for a long time, because after like 15 sec of pressure the device will reset itself to factory settings, and you DO NOT want that.

 

Watch the lights as they will progressively work their way back to the configuration you noted at the beginning.  It can take a couple of tries for the device to "resync." So don't be alarmed if half the lights are looking correct and suddenly they all go out again on their own and the whole process starts again.  If you're nervous, walk away for 5 or 10 minutes, and when you come back the Arris lights should be looking normal again.

 

Then, plus the power back in on your printer...make sure it rejoins the network by looking at the picture of the antenna to the right of the touch panel ... the blue light will stop blinking and go steady once it has resync'd.

 

Finally, power on your iDevice (folks recommend being 6 to 10 feet near your Arris, but I'm not sure that's really important) and try to print from an application you know has the capability...like Safari.  I'm sure you know the drill by now...click on the action icon (swooping arrow) select print, and it will either list the name of your printer, or you will have to try to select printer.  If you see the name of the printer, you are good to go.  Otherwise it will likely say "No Airprinters found" and you know you have to go to more drastic measures.

 

I should note that powering down and resetting the devices should be done in the order explained above.  Also, some people have found this will get them working for a few weeks, and suddenly they "lose" the printer again.  The only explanation I can think of for this is that Comcast sometimes does maintenance in off-hours, and they may even remotely reset your Arris if they are, say, pushing out firmware updates in the wee hours of the morning...and that *could* cause the resyncing among the devices to get hosed up.  Anyway, be aware that this solution may work not at all, only once, temporarily... but it's the easiest thing to try first.

 

The next more complex solution will be in the next post.

Contributor
mamalloy
Posts: 5
Registered: ‎06-16-2013

Re: Arris TG 862 modem/router and problem with air print

The next thing to try is a little more involved, because it requires you to mess with settings on the Arris.  This is starting to get a little out of my lane, but from what I understand Airprint wants to use a particular port, and by default the Arris does not know this.  So you need to access the Arris using a browser...in the address bar you need to enter its IP...the default on my Comcast configuration is 10.0.0.1.  Then you have to log in...the default credentials are "admin" for the username and "password" for the password.  If this does not work, you will need to go into the knowledge base on your Comcast / Xfinity site and google for "router IP" and hopefully you will hit on some help that will tell you this information.

 

Once you've logged on to the Gateway panel, along the left edge click on Advanced

Click on the "Enable" button next to Port Forwarding

Then click on Add Service

Enter these values:

Services name - Other,

Service Type - select UDP, 

Other Service - enter Bonjour,

Server IP Address - enter the printer address (you can get this from the front panel of the HP by touching the antenna icon),

Starting/Ending Port - enter 5353 for both values

select Save

logout

Now you have to go through the reset ritual described in the previous post.

Now re-try printing...Hopefully this will work for you.

If not, there is one last option.  See next post.

 

Contributor
mamalloy
Posts: 5
Registered: ‎06-16-2013

Re: Arris TG 862 modem/router and problem with air print

The last option is to get the Arris out of the picture...sort of. 

Buy yourself a wireless router that is known to be Airprint compatible...you can google around and find some guidance on that.

Put the Arris into "bridge mode" ... this will require calling Comcast customer service and talking to the tech people.

Use one of the network ports off the back of the Arris to connect the wireless router.

Set up the home network and get device all back onto it.

OR

Go to the Geek Squad people in Best Buy and tell them you want to buy your own device to replace the Arris...but it has to be Airprint capable.  They will be able to steer you in the right direction much more readily than the tech folks at Comcast (in my experience).

Replace the Arris with your new device, reconfigure, get the network back up and all devices on it.

Presumably at this point you have factored out the Arris from the wireless printing, so you should be good to go.

 

Sorry I can offer fewer details on this option because thankfully I have not had to go this route; option 2 worked for me.  My advice, if you have to go this way, is to go to the Geek Squad in either case and get their help setting up your alternative configuration, unless you are extremely tech savvy.  I have found it is cheaper (in terms of my time spent) to have them come out and set up the wireless network than to have a Comcast technician doing it or to try to do it myself.  When I've had the Geek Squad come out, they have gotten things up and running in < 30 min.  The last time I moved I let the Comcast technician and it took multiple trips and additional services changes on my bill because the fellow really didn't know what he was doing.  The Geeks do it all the time and know all the little quirks of the Comcast system.

 

Good luck!   Just don't give up on HP because of this experience.  It really isn't the printer's fault.  I have owned several different makes and models of printers, and HP's are the best in terms of ruggedness and quality of the print. So I hope one of the options I've explained works for you. 

New Visitor
Macaddicts
Posts: 1
Registered: ‎02-12-2014

Re: Arris TG 862 modem/router and problem with air print

Mamalloy,

 

Thank you for taking the time to write this post. Option 3 worked for me.   I was able to put the Arris into bridge mode with comcasts tech support people over the phone and purchased, an apple branded airport express base station for all of the routing services.  Ran one Ethernet cable from the Arris to Apples Airport Express.  Now everything is working!  

Note: you have to put the Arris into Bridge mode or it will somehow conflict with the airport base station.

 

Note when using the Arris as a router :  On an Apple/Mac laptop running OS 10.6.8 Safari would not load however Firefox would.  Any wireless printer would not print via any iOS device [iPhone, iPad etc.] with (airprint) on the Arris TG 862 modem/router/wireless to an HP Officejet 6700 Premium e-All-in-One Printer.

 

Thanks!