Reply
Contributor
Posts: 5
Registered: ‎12-02-2006

Slow wifi with excellent signal

 

Hi,

I am having trouble with slow wifi speeds.  I am using a Motorola SBG901 wifi modem (no router) with security enabled.  Plugging directly into the modem, the speed is great, however the wifi is slow.  It doesn't matter if I am right next to the modem even.  I have tried connecting with both my laptop and desktop (one is windows XP and one is windows 7) and the same thing happens.  It connects for about 30 seconds at 54 Mbps and then immediately starts dropping, ending up usually at 1Mbps and that's it, statys at 1.  I live in an area with a lot of wifi networks, not sure if something may be interfering or what the issue is.  The signal is always listed as excellent even though the speed is slow.

 

Thanks for your help.

Connection Expert
JamesR
Posts: 6,423
Registered: ‎09-29-2007

Re: Slow wifi with excellent signal

[ Edited ]

Things that can affect it are

Neighbors getting ou your router and sharing your bandwidth  -- Set up your Encryption

Neighbors Routers interfering with yours  ---  Change your channels

Microwave ovens/Cordless phone bases and other 2.4gigahertz devices interfering --- provide separation

 

 

Contributor
Posts: 5
Registered: ‎12-02-2006

Re: Slow wifi with excellent signal

 
Contributor
Posts: 5
Registered: ‎12-02-2006

Re: Slow wifi with excellent signal

 

How do you "change channels" on the modem?  I don't have a router.  Thanks.

Networking Expert
kevj
Posts: 4,813
Registered: ‎10-03-2003

Re: Slow wifi with excellent signal

You do have a router....the Motorola SBG901 is a combined modem/router. Browse to http://192.168.0.1 or 192.168.1.1 and you should be able to log in to it.

 

If neither of those work, run ipconfig /all from a command prompt on your PC/laptop, and look for the address of your default gateway, then browse to that IP

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

I don't work for Comcast...


Help us to help you!!
- respond to requests for info
- post back if your issue is resolved
- mark appropriate posts as solutions


Send feedback to Comcast using the 'feedback' link on this page:
http://www.comcast.com/Corporate/Customers/CustomerGuarantee.html?SCRedirect=true

Contributor
Posts: 5
Registered: ‎12-02-2006

Re: Slow wifi with excellent signal

 
Contributor
Posts: 5
Registered: ‎12-02-2006

Re: Slow wifi with excellent signal

 

Ok, I can log into the modem like that.  But you haven't told me how to change channels?

Service Expert
Bartleby
Posts: 5,499
Registered: ‎11-10-2003

Re: Slow wifi with excellent signal

If you don't have a manual, see the links available at this clickable link to Motorola's site for SBG901 modem.  That should get you pointed in the right direction for the modem's interface.

Connection Expert
JamesR
Posts: 6,423
Registered: ‎09-29-2007

Re: Slow wifi with excellent signal


smile145 wrote:

 

Ok, I can log into the modem like that.  But you haven't told me how to change channels?


When you log in , you should see some Tabs.  Look for Wireless and then you should see settings that you can change.  Then change the channel to one of the channels between 1 and what ever top channel is available to you.

Recognized Contributor
Posts: 1,158
Registered: ‎11-26-2003

Re: Slow wifi with excellent signal

There are two free software packages that can help you find the channel with the least interferenceIf you are running Vista or later, then you want to download Vista StumblerIf you are using older operating systems, you want to download NetstumberBoth of these packages work the same and will list all the wireless routers that are near you, the channel that they use, and the signal strengthIdeally, you want to select a channel that has 5 channels separation from any of the othersThis is because each channel overlaps the frequency of adjacent channels; to completely eliminate the overlap, you need to separate them by 5 channels.

Connection Expert
JamesR
Posts: 6,423
Registered: ‎09-29-2007

Re: Slow wifi with excellent signal


kentshaw wrote:

There are two free software packages that can help you find the channel with the least interferenceIf you are running Vista or later, then you want to download Vista StumblerIf you are using older operating systems, you want to download NetstumberBoth of these packages work the same and will list all the wireless routers that are near you, the channel that they use, and the signal strengthIdeally, you want to select a channel that has 5 channels separation from any of the othersThis is because each channel overlaps the frequency of adjacent channels; to completely eliminate the overlap, you need to separate them by 5 channels.


Thanks for the input.  I have an App on my Droid X callled WiFi Analyzer that performs the same function but not everyone has a Droid and these two programs seem to be a valuable addition to the Troubleshooting toolset. :smileycool:

Recognized Contributor
Posts: 1,158
Registered: ‎11-26-2003

Re: Slow wifi with excellent signal

One other thing to try.  Go into your router configuration and select only the wireless protocols you need.  If you do not have any devices slower than g or n on your network, then disable b.  The wireless routers work like a party line when you have other adjacent routers on the same channel or interference with adjacent chanels.  When your neighbor turns on his old Palm running at b or turns on that old printer that only supports b, your router slows down to that speed temporarily to maintain communication.

New Visitor
futbol90
Posts: 1
Registered: ‎03-22-2013

Re: Slow wifi with excellent signal

I just recently switch from ATT to comcast. The first thing I notice was the speeds were incredible fast

(Hardwired) but then when I connected my other devices (wifI) I notice speeds were crappy!. I kept looking and looking until I stumble upon a post that referee to switch From WPA2 --> WPA because WPA2 would slow down speeds. So i gave it shot and I went from 3Mbps to 25 Mbps Download Speeds! And before my speeds were really inconsistent, but now my speeds are stable. So switching from WPA2 --> WPA worked for me.

 

I hope this helps anyone out there.

 

 

Link to the page WPA2 VS WPA

 

"Some techies point out that using WPA2 requires Wi-Fi hardware to work harder in running the more advanced encryption algorithms, which can theoretically slow down the network's overall performance compared to running WPA."

Connection Expert
EG
Posts: 42,191
Registered: ‎12-24-2003

Re: Slow wifi with excellent signal

That would also depend on the particular device. Some hardwares are better at running WPA2 than are others. Two and a half year old thread now closed.