Reply
New Visitor
Posts: 3
Registered: ‎06-02-2009

Smart Phone won't connect to home wifi

I recently purchased the new Samsung Galaxy S3 and can not get it to connect to my home wifi. It connects to other wifis, just not at home.

 

Perhaps our modem is too old? Samsung tells me the phone can only connect to WPA, but when I switch my modem to WPA it still doesn't work. The only WPA option I have is WPA-PSK.

 

I feel like I'm in over my head with this stuff. Please tell me it will be an easy fix and not affect the other laptops and wireless phones in our hom:smileyconfused:

 

Thanks in advance.

 

Silver Problem Solver
reasd
Posts: 6,127
Registered: ‎02-22-2007

Re: Smart Phone won't connect to home wifi

Hello,

Try searching the web and you will find lots of solutions to your connect to wifi problems.

New Visitor
Posts: 3
Registered: ‎06-02-2009

Re: Smart Phone won't connect to home wifi

I've googled for days and haven't found the solution. Which is why I'm asking here.

Connection Expert
EG
Posts: 41,770
Registered: ‎12-24-2003

Re: Smart Phone won't connect to home wifi

Besides the type of security protocol being used which must match exactly between it and the router, so must all of the wireless settings match including whatever the wireless password is that the router is currently using.

Recognized Contributor
sabretooth
Posts: 351
Registered: ‎12-15-2011

Re: Smart Phone won't connect to home wifi

First, remove all security off the router.  Now try to connect to your SSID with no security temporarily.  If connected and verified, go back and add your security WPA2-AES with your passcode.  Make sure your MAC filter is off.

New Visitor
ghowessr
Posts: 2
Registered: ‎05-06-2013

Re: Smart Phone won't connect to home wifi

I had same problem, and no matter how many times I told it to "forget" the connection, scan, and create a new connection it would respond with "invalid password" (error response overlays the typing area so hard to see).

 

I did as sabretooth suggested and changed security to NONE, connected my Galaxy, went back into router config and changed back to WPA/WPA2-PSK (TKIP/AES) and set network password.  Disconnected Galaxy, re-scanned, connected, and gave password --- and it worked.

 

Puzzling why it didn't work before as I had security and password set the same.

 

New Visitor
ghowessr
Posts: 2
Registered: ‎05-06-2013

Re: Smart Phone won't connect to home wifi

An update on my earlier post... After finally getting my phone connected it later disconnected and refused to re-connect, even using the procedure sabretooth suggested.  

 

After hours of trial and error, calling the helpless desk (who wanted to charge me $40 + $9.99/month before they would give me tech help on my NEW router/modem), and doing every search I could think of, I finally found the "real" problem (for me at least).

 

The Comcast (Xfinity) modem/router combination is limited to FIVE (5) wireless connections!!  Of course this isn't documented anywhere.

 

My solution was to re-install the Linksys router this router/modem combo was supposed to replace, and plug it into one of 4 Ethernet ports on back of new router/modem.  I'm sure something will go bad, but for now I can connect all my devices:  DirecTV whole home ring (2 DVRs, 2 receivers), 3 computers, 2 Galaxy SIII cell phones, Tablet, and 2 Nooks.

Connection Expert
EG
Posts: 41,770
Registered: ‎12-24-2003

Re: Smart Phone won't connect to home wifi

[ Edited ]

ghowessr wrote:
My solution was to re-install the Linksys router this router/modem combo was supposed to replace, and plug it into one of 4 Ethernet ports on back of new router/modem. 

FWIW, if you have done this then you actually should have the CC supplied gateway device put in to *bridge mode* by them so that it becomes a plain vanilla cable modem. Cascading two routing devices results in a double NAT condition (Google for info) which can cause some issues for your home network.

New Visitor
561-654
Posts: 3
Registered: ‎05-18-2013

Re: Smart Phone won't connect to home wifi

Absolutely right! As soon as I deleted some devices, my smartphone showed up as connected. I just got CC's modem/router. Fortunately it can be returned. I will get a different router/modem that accepts more devices. TY

New Visitor
KREB327502
Posts: 1
Registered: ‎07-08-2013

Re: Smart Phone won't connect to home wifi

Thanks for the info sounds like my problem having more than 5 connections....no wonder my smart phone keeps falling off the grid
New Visitor
yenemar
Posts: 1
Registered: ‎07-16-2013

Re: Smart Phone won't connect to home wifi

In order to connect your samsung device, 

1. go to settings

2. select wifi

3. click on menu and choose WPS pin entry, it will give you the pin to enter into the router

4. login in to your router (from a laptop, open browser and type 10.0.0.1 and username = admin and password = password

5. go to wifi and click on add wifi protected setup (wps) client

6. choose pin settings

 and enter the pin from step 3

7. wait for a few minutes and your device will be connected