Reply
Contributor
elehtis
Posts: 5
Registered: ‎11-02-2011

"Oops, looks like you didn't finish..."

I peridodically (every week or two) get this message first thing in the morning when I open my MacBook Pro (OS 10.6.8), and until I confirm my login details (userID/p-word) and download yet again the Comcast xfinity installation package (ComcastDesktopInstaller_MMF2.pkg), I am blocked from Internet access via web browser, email, etc. This is really annoying, and no matter how many times I go through the steps, just to make it go away once and for all, I get re-directed at the end to a Welcome.jsp page that no longer exists, so that I can't "complete" my installation, ensuring yet another visit to Comcast netadmin purgatory someday soon.

 

Access to the internet actually returns as soon as I begin the download.

 

Am I doomed to re-enacting this tedious version of Groundhog Day for as long as I am a Comcast customer?  :smileycry:

Web Page Expert
BethKatz
Posts: 6,191
Registered: ‎11-14-2006

Re: "Oops, looks like you didn't finish..."

You don't need to install anything on your Mac to connect to the Internet. It should just work.

 

I'm not sure how to proceed from here, but I'll nudge some people to look over here and advise you.

Contributor
elehtis
Posts: 5
Registered: ‎11-02-2011

Re: "Oops, looks like you didn't finish..."

Yes, you are correct, I don't need to "install" anything, however I do peridoically need to download the package again. Yes, it "should just work", and does--usually. However, about once every two weeks or so, I have to go through this rigamarole of downloading the install package. Until I do, I don't have access to internet.  Thanks for responding, and for your help.

Web Page Expert
BethKatz
Posts: 6,191
Registered: ‎11-14-2006

Re: "Oops, looks like you didn't finish..."

You shouldn't have to download anything periodically. 

 

I don't have an answer. No one wandered over here to help. I nudged harder.

Web Page Expert
BethKatz
Posts: 6,191
Registered: ‎11-14-2006

Re: "Oops, looks like you didn't finish..."

Can you find this file in your Applications folder and throw it in the trash? Then empty the trash. 

 

You don't need anything installed by Comcast to use your internet connection. If you can find a way to uninstall it, that would be best. 

Networking Expert
Baric
Posts: 24,238
Registered: ‎07-28-2003

Re: "Oops, looks like you didn't finish..."

[ Edited ]

I wish Comcast installers weren't such idiots sometimes.  While NO software is required to register/provision your cable modem, the installers are taught to use this really stupid software package that lets them bypass the phone call to register the modem on the Comcast side.  What's worse is they then LEAVE this piece of junk on your system because they were lazy, got distracted, or plain had no clue what they are doing.

 

Joel's post here has instructions for how to remove the login item that prompts you to do this when you login.  Afterwards, reboot to make sure it doesn't happen anymore.  Now check your Web and email access.  Do websites look normal or do you get redirected to the walled garden page or some other Comcast setup site?  If so, check your TCP/IP settings for hard coded DNS servers.  If you have some, remove them and renew your DHCP lease (or reboot).

 

If still having a problem, call Comcast and have them re-provision your cable modem on their end, the registration may have been done improperly.  You will need the exact modem model number, serial number, and HFC MAC address (this should all be on the device label on the back or bottom the unit).

Contributor
elehtis
Posts: 5
Registered: ‎11-02-2011

Re: "Oops, looks like you didn't finish..."

Thanks, Baric. There are no artifacts in my startup file, and nothing is manually set in TCP/IP. I'll call Comcast and get my modem re-provisioned.