Reply
Regular Contributor
Posts: 80
Registered: ‎07-10-2003

Norton not supporting Firefox 16.0.1

Mac OS 10.6.8

Norton AntiVirus 11.2.2

Norton Confidential 1.4.4

Norton LiveUpdate 5.2.3

 

After updating Firefox to 16.0.1 Norton has a pop-up saying: This version of Firefox is not supported by Norton Confidential. You will not be protected while browsing the Web. Norton Confidential cannot protect you while you use this version of Firefox. Phishing Protection requires Firefox 1.5 or later.

 

This Norton package was downloaded from Comast.

 

I have used the Norton Live Update to try to update it.

And I have redownloaded Firefox 16.0.1 and re-installed it.

 

The pop-up from Norton continues every time Firefox is launched.

 

What can I or you do to regain phishing protection when using Firefox?

 

 

Security Expert
USAF_E-8_RET
Posts: 4,892
Registered: ‎10-28-2003

Re: Norton not supporting Firefox 16.0.1


19regor39 wrote:

Mac OS 10.6.8

Norton AntiVirus 11.2.2

Norton Confidential 1.4.4

Norton LiveUpdate 5.2.3

 

After updating Firefox to 16.0.1 Norton has a pop-up saying: This version of Firefox is not supported by Norton Confidential. You will not be protected while browsing the Web. Norton Confidential cannot protect you while you use this version of Firefox. Phishing Protection requires Firefox 1.5 or later.

 

This Norton package was downloaded from Comast.

 

I have used the Norton Live Update to try to update it.

And I have redownloaded Firefox 16.0.1 and re-installed it.

 

The pop-up from Norton continues every time Firefox is launched.

 

What can I or you do to regain phishing protection when using Firefox?

 

 


Hi 19regor39,

 

Not sure this applies, as I am not a MAC user and am not knowledgeable about all the differrent OS used.

 

http://community.norton.com/t5/Norton-for-Mac/Removed-NAV-Still-Get-Error-Msg-When-Firefox-Starts/td...

 

If that post does not answer your question, please look thru the rest of the Norton Mac Board.


Sorry I can't be more help.

A veteran - whether active duty, retired, national guard, or reserve - is someone who, at one point in his or her life, wrote a blank check made payable to The 'United States of America', for an amount of 'up to and including my life.'

Norton Expert
JonMcB_Norton
Posts: 148
Registered: ‎05-10-2011

Re: Norton not supporting Firefox 16.0.1

Checking on this for you... stand by.

Contributor
sickofitsalli
Posts: 10
Registered: ‎01-21-2012

Re: Norton not supporting Firefox 16.0.1

So sick of this I could scream.  When will this be fixed. Seems Norton/Comcast/Firefox need to get together and fix this, or stop the updates!

 

Norton Expert
JonMcB_Norton
Posts: 148
Registered: ‎05-10-2011

Re: Norton not supporting Firefox 16.0.1

I have been researching this for you - specifically FireFox patches for the NIS 4 product on OSX 10.6.  So far there is not a patch for it. My apologies for the inconvenience.

New Visitor
Posts: 1
Registered: ‎09-18-2006

Re: Norton not supporting Firefox 16.0.1

I was experiencing the same problem--the same pop-up appeared every time I launched Firefox.

 

There is a simple solution for getting rid of the pop-up, however, without removing Norton entirely.

 

First, if it isn't already disabled, turn off the Norton Confidential Toolbar by going to Tools > Add-Ons > Extensions in your Firefox menu.

 

Then, open Norton Confidential and disable Phishing Protection.

 

You should then be able to open Firefox without any further warning messages.

 

New Visitor
steveb1947
Posts: 1
Registered: ‎01-15-2013

Re: Norton not supporting Firefox 16.0.1

Norton does not support Firefox 18.0 either.  Their only suggestion was to upgrade the OS.  Unfortunately some of my software won't work with the OS upgrades.  I removed Norton as it was useless.

Contributor
Ropax
Posts: 5
Registered: ‎01-21-2013

Re: Norton not supporting Firefox 16.0.1

Comcast is offering an old version of Norton. Symantec has updated versions available, however Comcast's offering for the Apple platform is more than 2 years old. 

 

I've made this point to Comcast customer service but, so far, they have left those of us running Apple hardware out in the proverbial cold. 

 

Your options are: 

 

Pay for a new, supported version of Norton

Choose another product

Continue to use the free version without support for Mac OS X 10.7 or 10.8 or newer version of Firefox

Remove the product - not recommended.

Change your cable provider to one that includes free A/V that is not years out of date.

 

I run multple iMacs and a MacBook Pro. I've eschewed Comcast's offering for other products since up-to-date protection is a must.

 

It is unfortunate that Comcast has remained myopic on this. It is in everyone's best interests to ensure that protection levels are current for all users.