Reply
Contributor
kjakubowsk
Posts: 9
Registered: ‎03-19-2012

On Demand Error 7 on All Boxes

We have 3 boxes in our house:  two DCX3400 and one DCH-3416.

 

On Friday, we tried watching On-Demand and, after selecting channel 1, all three boxes displayed a message saying we needed to unplug the box for a minute and then plug it back in.

 

We did that on all three boxes and now all we get is the dreaded Error 7 on all of them.  I spoke to customer service yesterday and they sent refresh signals to all of them and nothing worked.  They are now sending a tech out on Tuesday to further investigate the problem (the person on the phone hinted that it was a line problem).  I find it very hard to believe that there is a line problem since we started getting the Error 7 right after the boxes instructed us to unplug them and replug them.  I also noticed that both DCX3400 boxes now have the flashing double-arrow on them.

 

Has Comcast ever given a real answer to what causes this?  I'm really hoping the techs don't just come out and try swapping our boxes because we have tons of unwatched stuff on all the DVRs.

 

I swear, between cable, phone, and internet, I am now on the phone with Comcast at least once a week.  :smileysad:

 

 

Contributor
MPEARCE
Posts: 18
Registered: ‎09-29-2011

Re: On Demand Error 7 on All Boxes

If you see my posts and plenty of others, there seems to be no answer or resolution to this Error 7/CL-7.  At least not ONE answer that fits all.  Some people seem to have it resolved with a new box or a reset, sometimes a technician seems able to resolve it. In my case none of those things have worked and we've been dealing with this for many months now. 

Contributor
kjakubowsk
Posts: 9
Registered: ‎03-19-2012

Re: On Demand Error 7 on All Boxes

After I got home from work yesterday, a Comcast Tech called me (which was weird because my appointment wasn't scheduled until today).  He said that he saw I had an appointment scheduled for today because my On-Demand wasn't working.  He then told me that he was in the area now because 6 or 7 people on my street were also having On-Demand problems.  He said the problem was a "front-end" problem and that they were already working on getting it fixed and that I did not need my appointment for today and that he was going to cancel it for me.  A half hour later, my On-Demand was back up and running fine.

 

I really hate how Comcast always wants to schedule service calls when it seems like 99% of the time a service call isn't needed and it's a Comcast network problem.

Contributor
MPEARCE
Posts: 18
Registered: ‎09-29-2011

Re: On Demand Error 7 on All Boxes

Good for you, hope it STAYS fixed for you!  We should all be so lucky :smileyhappy:

Regular Contributor
Zestyteich
Posts: 28
Registered: ‎03-25-2012

Re: On Demand Error 7 on All Boxes

I just had my Comcast installed yesterday and am getting an error7. Any ideas on what to do?
New Visitor
Dotster
Posts: 1
Registered: ‎05-21-2012

Re: On Demand Error 7 on All Boxes

So I thought it was just my level of service since I just transfered service to a new area and I thought  error 7 was normal for customers who had the limited basic package in this area.  It's good to know I am not alone. But it also looks like I need to start complaining...or call AT&T.

New Visitor
Posts: 1
Registered: ‎09-24-2007

Re: On Demand Error 7 on All Boxes

 
New Visitor
Posts: 3
Registered: ‎02-23-2004

Re: On Demand Error 7 on All Boxes

If you box was activated and shut down you must wait 20 minutes for all features to be downloaded, then turn the box on and the error code 7 should be cleared and features restored.

New Visitor
Posts: 1
Registered: ‎07-03-2006

Re: On Demand Error 7 on All Boxes

Has Comcast found a solution? After  3 attemps at "unplug" and a call to customer service - no luck! This is my 2nd box. Now, every reset, the "data" LED bilnks for at least 2 days. After 2 days I get 1 day of On Demand......then back to Error 7. And I upgraded all my cables!