Reply
Contributor
CourtneySF
Posts: 13
Registered: ‎09-29-2011
Accepted Solution

VOD: Persistent Error 7 on new DCX3400 DVR

Hello,

I've read through the FAQ and several of the threads in this forum which have been very helpful with other issues but after trying everything, I have been unable to get rid of my Error 7 when attempting to access VOD on my new DCX3400 DVR.

 

Here is my situation:

I have had the same DVR box for the last few years, it was a Motorola DCT 6412.  It recently broke (stopped powering up) so I exchanged it yesterday at my local Comcast store for a Motorola DCX3400-M. 

 

I had a few hiccups during installation yesterday, such as my premium channels not coming in, and several calls to Comcast tech support fixed that by sending a validation and initialization hit. There was also an issue with my MAC and emac information missing so I called a few more times and finally found a tech support person to fix that too. Side note - often times the rep on the phone will not even try to help me with my problem and will simply suggest to make an appointment with a technician.  I hang up and call back and hope that I get someone new who actually has an interest in helping me.  I would say 1 time out of 6 I will get someone on the phone who attempts to be helpful.  I refuse to go on a tirade here about poor customer service, I know the admins on this board have nothing to do with comcast's deficiencies.  My tactic is to just keep trying until I get someone who has a clue.

 

It has been almost 24 hours and I still do not have VOD. I have never had a problem accessing VOD before.  I live in San Francisco and I am not aware of any outages and when I called tech support this morning, I did not hear an outgoing message saying there were any issues in my area.  My cable is plugged directly into the DVR. The DVR is plugged directly into the TV. I have only one tv and one DVR box. I do not have any splitters. My tv does not get HD so I do not watch HD channels.  I have 3 premium channels.  

 

Again, let me stress that I never had VOD issues or loose connection issues with my DCT 6412.  At the moment, my guide is slowly repopulating itself (it has been 30 minutes and most everything is still "To Be Announced" and the menu only extends to 2 hours past the current time.  I am hoping the menu will sort itself out over the next few hours.  If most of the guide still says "To Be Announced" by this time tomorrow morning, should i be concerned?

 

I ran diagnostics and checked "interactive status."  My IP address is blank and the status is "wait_so_ack."  I understand that this could indicate a signal issue but my signal was totally fine yesterday prior to my DCT 6412 box dying.  My cable connection is firmly attached to my new DCX3400 DVR.  I double checked that 3 times.  I also power cycled (rebooted) my DCX3400 twice following the advice I read on this forum, hoping that the IP address would show up afterward but that did not work. I called Comcast and their phone tech support person (Sonya?) told me that she would send a signal to my box that would clear up any error messages and would fix my VOD and also my slow-loading guide information.  The box shut down and restarted as expected when she sent the signal, but it did not change my error 7 and the guide is still taking forever to download show title information.   I have doubts that the problem is with my outside connection or my cables and cords indoors as I have not moved or changed anything other than swap out the box.  From what I have read in this forum, having a technician sent out could likely be a waste of time and I really do not want to have to take time off of work (unpaid!) for a technician who cannot guarantee a fix. I would like to pursue troubleshooting this on my own as far as possible.  Please let me know if any diagnostic information would be helpful for me to post and I will do that.

 

Is the Error 7 and lack of VOD due to the missing IP address?

How can I get an IP address to be pushed to my box once and for all?

Except for VOD, my DCX3400 works perfectly and appears to be brand new.  Do I need to swap it out again? 

 

Please advise!  Thank you for your attention on this and I hope you can offer me some kind of solution.  Since I have been unable to talk to anyone other than front line support on the phone, if you are able to forward my issue on to someone with more technical expertise at Comcast, that would be great. 

Cable Expert
JayInAlg
Posts: 11,327
Registered: ‎03-02-2007

Re: VOD: Persistent Error 7 on new DCX3400 DVR

Error 7 is because there is no IP address, and since you had a working box before, I'd point more towards an account coding issue with the box and your account than a signal issue.

 

Attempt to call another Comcast support agent and see if they can get the codes correct.  Otherwise, it can be escalated to Comcast Cares Team available on the forum, but it might not be until next week until they get back.

 

Try calling one more time and report back success or failure.

Contributor
CourtneySF
Posts: 13
Registered: ‎09-29-2011

Re: VOD: Persistent Error 7 on new DCX3400 DVR

Thanks, Jay!  I'm on it and will try again with phone support and be specific about the account codes.  I appreciate your help on this and will post back with my results as soon as possible. 

Contributor
CourtneySF
Posts: 13
Registered: ‎09-29-2011

Re: VOD: Persistent Error 7 on new DCX3400 DVR

They tried to get the internet dept to hit my box so that it would come up with an IP address, but it didn't work.  They said that people have re-initialized my box so many times, that it's a mess and I am better off swapping it out for another box and trying again. So that is what I am going to do, get another DCX3400 and give it another try.

 

This is going to drive me to drink.  A lot.

Contributor
CourtneySF
Posts: 13
Registered: ‎09-29-2011

Re: VOD: Persistent Error 7 on new DCX3400 DVR

My VOD is finally working!  After a couple of calls to get the activation of my box done correctly, last night I was able to view all channels including premium but my IP address was again missing and I was stuck with an error 7 again.  I decided to check again when I woke up first thing this morning and lo and behold, my IP address is now present and I can access VOD.  No idea why it took so long.  Possibly it might have to do with the box. 

 

The only issue I have left is that the guide only gives information for shows 3-4 hours ahead of the current time.  The rest of the guide menu says To Be Announced. The guide menu should have completed overnight.  I've NEVER seen the guide download information so slowly before!  I am worried about contacting comcast about it for fear of getting sent more hits to my box that might screw it up. 

 

One last tip:  Yesterday while I was on the phone with comcast, I was transferred to talk to someone in the internet dept who helped me to determine if it was possible for them to send update my box with an IP address.  She was knowledgeable.  She was unable to do it and we could check that by going to Menu > Setup > Cable Box Setup > Configuration > Select to display

 

In the messages field, there should be numbers (not just 0) and the numbers should change a couple of times per minute.  The Status field should also have numbers that keep changing.  My problem with my box yesterday was that the Messages field had a static 0 and that was a sign that my box was not communicating with comcast and the tech was unable to push an IP address to it.   Should I lose my IP address again, I plan on making sure I get forwarded to the internet dept and ask them to please push an IP to my box.

 

I hope this information is helpful for others.

Contributor
CourtneySF
Posts: 13
Registered: ‎09-29-2011

Re: Finally Got a Tech Who Knew What He Was Doing

That was pretty much my tactic the past couple of days.  I have talked to over a dozen different reps because my new DCX3400 didn't have an IP so I couldn't get VOD to work.  48 hours and 2 swaps for new boxes later, I finally have VOD working.  Whenever I would get a rep who was obviously clueless and wanted to just immediately schedule me for an onsite tech appointment, I would decline and call back to talk to someone else.  It's a hassle, but eventually you'll get to someone who has an interest in being helpful.  It is also useful to do as much research as you can on your own BEFORE you call so that you can tell the rep on the phone exactly what to do.  If you can identify what your problem is and can suggest what type of signal to send to your box or what account code they need to fix, they will usually do what you ask.  Waiting for a tech rep to figure things out has never worked for me.

New Visitor
PSG7PSG
Posts: 1
Registered: ‎10-01-2011

Re: VOD: Persistent Error 7 on new DCX3400 DVR

Any idea who you spoke with??  

 

I'm not having any luck getting someone who knows how to push an IP address.  I've tried speaking with supervisors but it's not getting me anywhere except free HBO.

Contributor
CourtneySF
Posts: 13
Registered: ‎09-29-2011

Re: VOD: Persistent Error 7 on new DCX3400 DVR

Unfortunately, I didn't get a name of the person I spoke to.  But I do recall that they had to transfer me to the "internet department."  I believe that I was talking to the support desk that usually works with folks who have issues with their comcast internet service (I do not get internet through comcast, only cable tv.)

 

Update: It took 3-4 full days, but my menu guide finally populated with more than a week's worth of programming.  It took forever but I am glad everything seems to be working.

Official Employee
ComcastKeisha
Posts: 1,561
Registered: ‎09-20-2011

Re: VOD: Persistent Error 7 on new DCX3400 DVR

--

 

I am glad to hear that your issues were all resolved and your VOD is now working without any issues.

Thank You
-Keisha-
Official Employee
ComcastKeisha
Posts: 1,561
Registered: ‎09-20-2011

Re: VOD: Persistent Error 7 on new DCX3400 DVR

---

 

I am sorry that you are having issues with your VOD service. Can you please send me a private message with your issue, name and account number and I will look into this for you. Please copy your post in the body of the email as well.

Thank You
-Keisha-