Reply
New Visitor
Janou
Posts: 1
Registered: ‎09-18-2013

X-1 Box problems

I have had the new Comcast X-1 box for about a week and have several problems.  I am on my 2nd box and am still having problems with the DVR.  At first I had a connection problem.  I have a Sony Vega LCD TV (10 year old) and it has a DVI HDTV connection.  With my old cable box I used a HMI to DVI HDTV connecting cable and it worked fine, but with the X-1 box the connection doesn't work.  I had to then use the component cables, which worked for about a day then stopped working.  The Comcast service tech came to the house and replaced the box with a new box.  The component cables now work but I have multiple problems with the DVR.

I selected several series recordings and all appears fine, but when the program comes on, it does not record.  I have also tried to select record while watching a program and it will not record.  I then tried recording an individual program to record; I set it up to record at the correct time, a red dot appears on the priogram, it is listed in the programs to be recorded, but does not record.  Some of my programs had recorded, but many just don't.

 

I contacted Comcast who is sending ou another tech today to check/replace the box again.  Do these boxes ever work correctly or is this par for the course for the X-1 boxes?

 

Also last night I went to select several channels to watch and nothing happened.  I was able to get some of the basic channels, but when I selected ch 100, nothing happened.  I selected different ways to get there; entered in 100/OK; brough up ch guide/selected channel; went to ch 99 and selected ch up button, but it would not go to the channel (is also happening today).

 

I have unplugged the box a couple of time and allowed to reboot and have selected restart from the tools menu, but still have the DVR not recording problem.  Are there any suggestions?  I see that Comcast is comming out with a new X-2 box, is that any better and when will it be available?

 

Thank you!

New Visitor
TXN8tive
Posts: 1
Registered: ‎12-02-2013

Re: X-1 Box problems

When you receive your second DVR, they often do not deregister your first DVR and unless you manually update your X1 settings, the series tries to record to the old DVR - go to settings on your X1 box (Xfinity button then to the end where it looks like a gear) third option - Preferences then General then DVR for scheduled recordings - there is actually a pull down by the label schedule on:  if there is more than one selection, you need to change it to the other option.  I went out to xfinity.com and went to my DVR manager and changed the old boxes to start with ZBad so I could easily distinguish them..  You should be able to record and view after that.