Reply
New Visitor
MJ49
Posts: 3
Registered: ‎06-02-2013

XI Response and Blank screen

We recently got the new XD1 DVR and so far have not been impressed. It is slow in booting up, slow in responding to commands and will at times give a blank screen then show Xfinity in the screen and display that it is rebooting. This rebooting can take anywhere from 2-3 minutes which is frustration if you are watching a ball game. Is there anything that can be done to correct these issues?

New Visitor
MJ49
Posts: 3
Registered: ‎06-02-2013

X1 is worthless

After recently getting the "new" X1 DVR I now understand why the posts concerning this box of a year ago were not favorable at all. This box is a piece of junk. I would think that before Xfinity or Comcast release a product to the field they test it to make sure that it functions. Obviously this was not done. When I had a technician in to give me a new X1 box thinking I just got a bad one he confirmed there were problems with this box. So many that even his wife will not use this new box. I am very disappointed in the quality of the products that the only cable company that we have access to provides where they cannot compete with the satellite dish companies and their equipment.

New Visitor
01020
Posts: 2
Registered: ‎02-15-2014

Re: XI Response and Blank screen

I have had nothing but problems with the X1 platform since I got it. I had high expectations, but after getting it it constantly goes in and out along with my internet. Before I switched I did not have that many problems as I do now. I am seriously seeking other alternatives to comcast these days.