Reply
New Visitor
greatscot523
Posts: 2
Registered: ‎08-13-2011

DVR won't play, no error message

I have the cisco RNG2000N xfinity dvr box. It records my programs just fine, but when I go to play my recordings, they don't play. I just get a blank screen with a status bar (like the one that has the play/pause button and shows how far along in the recording you are) and the recording never plays and I don't get an error message, either. What do I do to fix this?

 

I've also been having a problem with the tv I have in my bedroom where the sound goes off sporadically (it only goes off during ads, though, which is odd but convenient!) on all channels and then TNT comes in with this constant pebbly grinding sound w/ no audio from the show or ads coming through (this doesn't happen on my main tv w/ the dvr box). If this is a "connection/signal issue", what do I do to fix it? is there a way to do it without a tech, cause my apartment building has major comcast problems and it feels like everytime a tech comes out for someone else, my internet goes out for days til I can get another tech out to fix it....this is the first week in a month that i haven't lost my internet, and i don't want to jinx it!

 

thank you!

Contributor
ScaryBeth
Posts: 9
Registered: ‎06-09-2011

Re: DVR won't play, no error message

For the DVR issue, try resetting your box by unplugging it from the power for 30 seconds and plugging it back in. If there's no error, it's probably just a glitch in the box and most of the times a reset will fix those.