Reply
Contributor
Posts: 12
Registered: ‎01-17-2008
Accepted Solution

Screen goes black switching from HD to non-HD channels

On my new DCX3499-M box I replaced the RGB cables with HDMI for my Sony Bravia LCD TV.  Now when I switch from HD to and from a non-HD channel the screen go black, audio is present.  If I power the TV off and then on the picture returns.  If I switch channels again the problems reoccurs.  If I stay within HD channels then the picture stays on, or conversly if I stay in the lo-def channels the picture stays on. 

 

I like the better HDMI picture but I need to be able to go between lo and hi def.  

 

Can you tell me what the issue is and provide a solution, please?

 

I tried a new HDMI cable that was the latest and greatest.  Same results.

 

Thank you.

New Visitor
jpwarhal
Posts: 4
Registered: ‎03-06-2012

Re: Screen goes black switching from HD to non-HD channels

It sounds like you have the same problems I have. I found that when I am using the on demand feature if I press the fast forward button it gets it off the black screenand then it goes to the movie I selected. Another issue was sound with HD and a new HDMI cable solved that. As far as other blackout issues I have not been able to find fixes for them other than re-setting the equipment. Be aware that you will be charged to have them out to fix any problems!!!!!

Contributor
Posts: 12
Registered: ‎01-17-2008

Re: Screen goes black switching from HD to non-HD channels

I don't think this is the same problem you are having.

Contributor
Posts: 12
Registered: ‎01-17-2008

Re: Screen goes black switching from HD to non-HD channels

Problem solved.

 

I found this post and it worked.

 

I know my TV (34" Toshiba CRT) doesn't like switching between SD and HD channels constantly, so I set the Moto 4:3 Override setting to 'stretched' and now my TV is happy. You might give that a try.

Access the Moto settings by having your tv ON but the comcast box OFF. Then press the menu button on the Moto and you can use the scroll buttons to adjust the 4:3 Override. You could also try the other settings to see if they work better for you.