Reply
New Visitor
Posts: 3
Registered: ‎01-05-2005

X1 - Black Screen

The screen went black except for the Xfinity logo. This means my TV was getting a signal from the X1 box. The X1 box was just sending that image. This was over HDMI. I still had audio.

 

The guide and Xfinity buttons did nothing. Nor did the channel up/down or number buttons. I could tell the channel wasn't changing because of the audio.

 

The power button did turn off the X1 box but turning it back on just went back to the black screen with the Xfinity logo.

 

I finally unplugged the box and plugged it back in, which takes a while to reconnect before it is usable again. A few minutes later, the screen went black again. I had to unplug and re-plug it and wait a while again.

 

This started during the Maple Leafs vs. Bruins Stanley Cup playoff game near the end of the 3rd period. I nearly missed the Bruins come-back, I missed the end of the period not know if it stayed tied. The only reason I didn't miss the winning goal was because the fans delayed the game so much throwing stuff on the ice.

 

The new X1 features are nice and all but it's no good if I cannot depend on it to work. I've also had the picture and guide freeze up a few times on me requiring that I unplug and re-plug it in again. This is my second X1 box and replacing it hasn't made it any better.

Regular Contributor
yosereli
Posts: 55
Registered: ‎06-27-2011

Re: X1 - Black Screen

its not the box its the software running the box, your issue is not uncommon and has been reported from what I see here many times.